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SOFTWARE LICENSE AGREEMENT 

Grant of license 
Rasterex grants you the right to install the Software on one (1) computer or one (1) 
network server at any one time. Rasterex also grants you the right for one (1) User (or in 
the case of a Network License, the number of Users stated on the purchase agreement) 
to activate the Software at any one time. This license is an overriding condition, whether 
or not further mechanical or electronic measures are used to prevent more than the 
purchased number of Users activating the Software at any one time. 

Copyright 
The Software is owned by Rasterex, and is protected under international copyright laws. 
You must therefore treat the Software as you would any other copyrighted material, 
except that you may either (a) make one copy of the Software solely for backup or 
archival purpose, or (b) transfer the Software to a single hard disk provided you keep 
the original solely for backup or archival purposes. You may not copy the written 
materials accompanying the Software. 

Terms 
This license is effective from your date of purchase and shall remain in force until 
terminated. You may terminate the license and this agreement at any time by destroying 
the Software and its documentation, together with all copies in any form. Rasterex may 
terminate this agreement if you fail to comply with any of the terms and conditions of it. 
Upon any termination of this license, you agree to destroy the Software and its 
documentation, together with all copies, modifications or portions of them in any form. 
You must provide us, on our request, written certification of such destruction. 

Limited warranty 
Rasterex warrants that, for a period of ninety (90) days of normal use from the date of 
original purchase, the CDs on which the Software is recorded will be free from defects in 
materials and faulty workmanship, and the Software will function substantially as 
described in the enclosed program documentation. Except for the aforesaid warranty, all 
products delivered pursuant to this agreement are delivered on an ”as is” basis and 
Rasterex, its distributors and dealers, expressly disclaim any and all other warranties, 
expressed or implied, including, without limitation, implied warranties or conditions of 
merchantable quality or fitness for a particular purpose. 

Limitation on liability 
Rasterex’s entire liability, and your exclusive remedy for any breach of the limited ninety 
(90) day warranty described above, shall be the replacement of any CD or program 
documentation not meeting with the warranty, that is returned to Rasterex or to one of 
its distributors or authorized dealers together with a copy of your paid receipt. 
Under no circumstances shall Rasterex, its distributors or dealers, be liable for lost 
profits, data or information of any kind, or for consequential, special, indirect, incidental, 
punitive or other damages that may arise through use of the product licensed 
hereunder. 
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GIF and other UNISYS LZW licenses 
Various Rasterex products provide read/write capability and/or other LZW capability 
covered by Unisys-owned U.S. patents 4,558,302, B1 4,558,302 and foreign 
counterpart patents. Although Rasterex is licensed under these patents, Rasterex’s 
license does not extend to software developers or third parties who wish to incorporate 
Rasterex software into their own products (e.g., by way of DLLs and APIs). It is the 
user’s responsibility to contact UNISYS CORPORATION to arrange a licensing 
agreement. Note that the use of such LZW technology without the necessary licenses 
will be an infringement of UNISYS CORPORATION’s copyrights and/or patent rights. 
Licensing information can be obtained by contacting Unisys at the following address: 
     Unisys Corporation 
     Welch Licensing Dept. - MSC1SW19 
     Township Line and Union Meeting Roads 
     P.O. Box 500 
     Blue Bell, PA 19424-0001 
     Fax: (215) 986-3090 
Inquiries may also be made via the Unisys Web site, http://www.unisys.com 

Governing law 
This Software license agreement is governed by the laws of Norway. 

Disclaimer 
Rasterex makes no representations or warranties regarding the contents of this guide, 
and specifically disclaims any implied warranties of merchantability of fitness for any 
particular purpose. Furthermore, Rasterex reserves the right to revise this publication 
and to make changes from time to time in the contents without an obligation by 
Rasterex to notify any person of such revision changes. 

Trademarks 
Rasterex Registered trademark of Rasterex 
RimEngine Registered trademark of Rasterex 
RimServer Registered trademark of Rasterex 
RxAutoImage Registered trademark of Rasterex 
RxBatchManager Registered trademark of Rasterex 
RxCapture Registered trademark of Rasterex 
RxCDManager Registered trademark of Rasterex 
RxFilter Registered trademark of Rasterex 
RxHighlight Registered trademark of Rasterex 
RxHighX Registered trademark of Rasterex 
RxIndex Registered trademark of Rasterex 
RxLock Registered trademark of Rasterex 
RxQuickView Registered trademark of Rasterex 
RxRaster Registered trademark of Rasterex 
RxReproScan Registered trademark of Rasterex 
RxSpotlight Registered trademark of Rasterex 
RxVectory Registered trademark of Rasterex 
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RxView Registered trademark of Rasterex 
RxViewSpace Registered trademark of Rasterex 
RxViewX Registered trademark of Rasterex 
ADI Registered trademark of Autodesk Inc. 
ADS Registered trademark of Autodesk Inc. 
AutoCAD Registered trademark of Autodesk Inc. 
AutoCAD 2000 Registered trademark of Autodesk Inc. 
AutoCAD LT Registered trademark of Autodesk Inc. 
Microsoft Windows Registered trademark of Microsoft Corp. 
Microsoft Windows 95/98 Registered trademark of Microsoft Corp. 
Microsoft Windows NT Registered trademark of Microsoft Corp. 
Win32S Registered trademark of Microsoft Corp. 
MS-DOS Registered trademark of Microsoft Corp. and 

International Business Machines Corp. 
All other brand and product names used in this product are trademarks of their 
respective companies. 
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Chapter 1 Introduction 

Welcome to RxHighlight and RxView R6 
RxHighlight has all the functionality of RxView, with additional markup, 
security and file conversion features. The programs run on all 
Windows platforms from Windows 95 SP1 onwards. 

RxView R6 
RxView R6 is a powerful explorer and viewer that can be used to view 
and print the following file format categories: 
• Documents 
• Spreadsheets 
• Drawings 
• Raster files 
• Pictures 
New and improved filters are continually under development. 
Viewing functionality 
Files can be loaded and viewed from local or network drives, and 
intranet and Internet addresses. Interpretation of files is fast and 
precise. Multiple files can be viewed simultaneously in separate 
windows, and these windows can be cascaded, tiled and split as 
required. Viewing is enhanced with functions including fast zoom, pan, 
page, file overlay, file compare and markup. 
Printing and plotting 
A powerful printing and plotting engine allows RxView R6 to be used 
as a printing station in technical offices. All Windows based printers 
and plotters are supported. 
Plugins 
You can attach plugins (.DLLs) to RxView to extend functionality, add 
commands (buttons or menus), activate and deactivate functions 
using dialogs etc. Plugins are available as they are completed, and 
can also be created by others to user’s specifications. 
See the Rasterex web for plugin availability:  
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3D Files 
The standard installation includes a trial installation of 3D formats, 
including Catia, SolidWorks, DGN, etc. 3D file formats are generally 
subject to separate licensing agreements as many of the file formats 
are supplied by third-party developers, e.g. Catia, ACIS, STEP etc. 
Contact your supplier for details and prices. 
Administration and Permissions 
User Profiles are set up to control creation, viewing, editing and 
deleting of markups, linking, and permissions for operations such as 
executing applications and printing. This powerful administrative tool 
gives control of user rights in design offices, technical environments 
and Electronic Document Management systems (EDM). 

RxHighlight  
Batch print and conversion 
Using RxHighlight you can batch process a large number of files and 
have them printed or converted to another supported save file format. 
File Save As 
Using RxHighlight you can save the active vector drawing to a 
different vector file or raster format. The file format (i.e. file type) can 
be selected from a list of the available formats. Any sub type can be 
selected using the options button if available. 
When saving to a raster format you need to specify number of colors, 
compression, size and DPI of the target format in a separate dialog 
that appear after you click the save button. 
Markup 
RxHighlight enables you to annotate file contents by adding graphics 
and text into markup layers. Markups are stored in separate vector 
files. Files can have multiple markup layers created by separate 
users. 
Linking 
RxHighlight also allows you to link related files. The link function 
creates buttons on top of the viewed file that link the file to other files. 
Clicking a link button loads the linked file. 
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Workflow Integration 
TDM / EDM (Technical and Electronic Document Management) 
systems can use RxView and RxHighlight as viewing and markup 
tools controlled by RxIndex or another database. 
File Security 
Markup and overlay file formats are proprietary to Rasterex. This 
guarantees security considerations. 
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Conventions 
In this document, the following text conventions apply: 
 
Bold text 1. Important notes. 

Italic text 1. Menu names. 
2. Software button texts. 
3. Dialog texts. 
4. Variables. 

UPPER CASE 1. Commands. 
2. Keyboard legends. 
3. Keys to be typed on the keyboard. 
4. File and folder names unless case-sensitive. 
5. Profile parameters. 

Courier 8pt 1. Application code to be typed in by the user. 

 
In this document, Menu > Submenu > Parameter is used to denote 
the route or chain of menu commands used to arrive at a particular 
dialog box, parameter or result. 

Support 
If you experience difficulties using this product, or if you have 
questions concerning this or other Rasterex products, contact your 
local supplier. Your local supplier’s name and contact information 
should be printed on the box in which this product was supplied. A list 
of the various national distributors is also available on the Distributors 
tab of Rasterex’ Home page, located at: 
 

http://www.rasterex.com 
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Chapter 2 Installation 
 
Note  This program runs on Microsoft Windows-based platforms, 
Windows 95 SP-1, Windows 98, Windows Me, Windows 2000, 
Windows NT and Windows XP. 

2.1 Requirements 
RxView R6 minimum requirements: 
• Pentium processor or higher. 
• Minimum 32 MB RAM (more RAM allows more open files). 
• 100 MB of hard disk space. 
• Internet Explorer version 4 SP-2. or higher 
• Windows-supported raster printer for hybrid printout. 
RxView runs in trial mode for 30 days. There are no limitations in trial 
mode. A valid license key can be bought and added at any time. 
You can choose to install either RxHighlight or RxView R6. Both are 
included in the RxView installation. 

2.2 Installation 
1. Insert the Rasterex CD into the CD drive on your computer.  
Or:   Click and run the download link for RxView. 
2. Follow the instructions  
3. When the appropriate dialog appears, type the folder in which 

RxView is to be installed. 
The default folder is \Program Files\Rasterex\RxView 

4. Click Continue. 
The installation program is straightforward and registers the program 
in the Windows registry. Use the Add/Remove Program dialog if you 
need to remove RxView 
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2.3 Network License Keys 
If you are installing RxView as a multi-user program on a network and 
you are using a network license, you need to install the Rasterex 
License Server on a server in the network. RxView needs to locate 
the License server or single license file in order to run. See the 
Rasterex License Server guide. 

2.4 Translation 
The file RxViewR6res.TXT contains the text strings used in the 
dialogs in the program. If you wish to translate the dialogs to a local 
language, use a standard text editor to change the text then save the 
file under the same name. RxView only reads the contents of the first 
double quotes in each line of RxViewR6res.TXT, so place your 
translation within the first double quotes! You may leave the original 
text next to your translation but outside the quotes for future 
reference. 

2.5 Documentation 
This user’s guide is included in your installation as a PDF file.  
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Chapter 3 Getting Started 

3.1 Overview 
This chapter describes the various parts of the RxView window and 
the most important features of RxView. You will find detailed 
descriptions of dialog boxes, toolbars and procedures in later 
chapters. Use any of the supplied samples to show the features, all of 
which are accessed through buttons and menus. 

3.2 Main Window 
Start RxView and the following screen or one similar appears: 

 
Figure 1 The RxView window 

As illustrated, the RxView window includes a work area, a Workspace 
Bar, menu bar and several toolbars above the work area. The bottom 
toolbar is the markup toolbar, and a status bar is placed at the bottom 
of the window. 
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3.3 Controlling the Toolbars 
When RxView R6 is opened for the first time, the “default” screen 
layout appears. This screen shows all the toolbars some of which you 
may not want to use.  
Place the mouse cursor in the toolbar area and click the right mouse 
button.  The following menu is displayed: 

 
Figure 2  Toolbar right-click menu 

Using this simple menu you can enable and disable the toolbars, the 
Workspace Bar and the File and Folder explorers. 
 
The majority of the RxView R6 screen components can be moved, 
opened, closed and resized to suit your requirements. The 
descriptions and illustrations in this chapter may therefore not reflect 
the current layout on your screen but it will be similar. 
Shortcut keys can be assigned to all functions. The procedure for 
setting and changing them is described in chapter 5. 
 
Toolbars that contain drop down selection boxes cannot be docked 
vertically as the drop down selection boxes then will become un-
available. 
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Many of the more commonly used menu items have been included as 
buttons on the various toolbars to simplify access. Cross-references 
are included in this manual where applicable. 

3.3.1 Standard toolbar 
• File operations - Open, Close, Save, Next, Find Text, Previous, 

Print, Print Preview, etc. Explorer and Workspace buttons. 

3.3.2 View toolbar 
• Viewing operations - Zoom, Pan, Rotate, Magnify, Bird’s Eye, 

Calibrate, Compare and Overlay. Measure and Background color. 

3.3.3 3D toolbar 
• Operations for 3D files - Rotate, Perspective, Wireframe and 

Cross- Section controls. 

3.3.4 Office toolbar 
• Standard operations for office formats including Word, Excel, and 

PDF - Page Up, Page Down, Zoom, Gridlines, Thumbnails etc. 

3.3.5 CAD toolbar 
• Operations for CAD files – Previous and Next Views, Previous 

and Next Layouts, Block Mode, Next and Previous Blocks, Block 
Attributes, Attribute Search, Pen Table, Vector Layer control and 
Entity info.   

3.3.6 Address toolbar 
• Load toolbar for most recent files. 

3.3.7 Markup Tools Toolbar 
• The markup tools toolbar buttons give access to drawing related 

markup features available in RxHighlight. See Chapter 13. 

3.3.8 Markup Settings Toolbar 
• The markup toolbar buttons give access to markup settings 

available in RxHighlight. See Chapter 13. 
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3.4 Status Bar 
The status bar is located across the bottom of the RxView window. 
This bar can contain the following information from left to right: 
• The current status of the application, or Help information. 
• Progress Bar – Indicates how the application is progressing 

through a process. This will be visible while the process is active, 
and will be hidden otherwise. 

• X Position – Is the position of the cursor within the active file, 
along the X (horizontal) axis. 

• Y Position – Is the position of the cursor within the active file, 
along the Y (vertical) axis. 

• Unit Type – Is the unit of measurement for the active file. This is 
selected in the Tools > Filter Settings menu, and applies for all files 
associated with the same filter. See chapter 5. 

• User Name – the current user name is displayed on the status 
bar. This can either be the windows user (default) or any user 
name specified in the Tools->User Signature function. 

3.5 Workspace Area 
The workspace area comprises the entire area of the screen except 
the areas covered by the menu, toolbars, the file and folder explorers 
and the Workspace Bar. Open files are displayed in this area.  
Any number of files can be displayed simultaneously. You can 
cascade the displayed files vertically or horizontally, or tile them, and 
you can split an active file’s window into four areas to enable you to 
view different areas of the same image at different magnifications. 
See later in this manual for more details. 
Tabs display on the lower edge of the workspace to enable fast file 
selection when many files are open. The file workspace cannot be 
hidden or moved, though other screen elements can be positioned as 
required around and in the workspace. 
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3.5.1 Workspace Area Right-click Menu 
Load a file into the Workspace Area and place the cursor in the 
display area and click the right mouse button to reveal a menu of the 
options available for the workspace. The options are the same as for 
the toolbars for the active file.  

3.6 Folder Explorer 
The folder explorer shows the folders accessible from your computer. 
Its layout and function are similar to that of the standard Windows 
Explorer. The files contained in folders located using the folder 
explorer are listed in the file explorer. The text “Folder Explorer” 
appears at the left end or above the window. The folder explorer can 
be resized, toggled on and off, and positioned anywhere on the 
screen. 
 

3.7 File Explorer 
Toggle the File and Folder file explorer using this button . Shows 
the various files contained currently active folder. The types of files 
listed will depend on the setting in the Files of Type toolbar. The text 
“File Explorer” appears at the left end or above the window. 
The file explorer can list the files in a number of ways: 
• Large icons. 
• Small icons. 
• A simple list. 
• A list with file details. 
• As thumbnail pictures. 
 

3.7.1 Configuring the Information Columns 
When the Details option is selected, the file explorer displays the files’ 
details in columns. You can decide which columns of information you 
wish to display. 
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3.7.2 Moving Columns 
When the Details option is selected, the file detail columns can be 
moved as required. See later in this manual for details. 

3.7.3 Sorting File Details 
The files listed can be sorted by name, size, file type, modification 
date and attributes, in either direction (up or down). 
• Click on the appropriate column button to select the desired sort 

method. 
• Click the same button again to toggle the direction (note the arrow 

indicating the sort direction). 

3.7.4 Opening Files 
Open files from the file explorer using standard Windows techniques: 
• Drag and drop – Click on a file to highlight it, then drag it out from 

the explorer and release it in an empty area of the workspace. 
• Double-click on a file to open it. 
• Go to the File > Open menu item and select a file. 
• To list only files of a particular type in the file explorer, click in the 

white part of the Files of Type list box or on the down arrow beside 
the box to open the pull-down selection list. Click on the desired 
file type to display only files of that type in the list. 

3.7.5 File Explorer Right-click Menu 
Place the cursor in the file explorer (but not on an actual file name) 
and click the right mouse button to display a pull-down menu of the 
options available for the explorer.  
 
If the cursor is located on a file name when the right mouse button is 
clicked, a standard Windows right-click pull-down menu will be 
displayed. 
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3.8 Workspace Bar 
Toggle the Workspace Bar using this button . The bar has three 
tabs, listing the blocks, views and layouts available for the active 
image. The text “Workspace Bar” appears at the left end or above the 
window. The color of the text will depend on the Windows display 
settings for active and inactive windows. 
The properties listed on the tabs depend on the type of file that is 
active and the attributes included with that file. 

3.8.1 Views Tab 
This tab lists the various views that are available for the file. For 3D 
files, eight standard views will be listed, plus any user-defined views 
that may be included in the original file. 

3.8.2 Blocks Tab 
Within a vector file, vector entities (lines, circles etc.) can be arranged 
into groups, called blocks, and the blocks can be named. This tab 
provides information about the various blocks of entities and 
references included in the file. 
The tree structure in this tab enables you to toggle each block 
individually. 

3.8.3 Layouts Tab 
A layout is used to compose or lay out a model AutoCAD drawing for 
plotting. A layout may consist of a title block, one or more viewports, 
and annotations. If a drawing contains layouts the Layout tab will be 
available, listing the various layouts included. 

3.8.4 Workspace Bar Right-click Menu 
Place the cursor in the Workspace bar and click the right mouse 
button to display a pull-down list of the options available.  
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3.9  Markups 
RxHighlight allows markup directly on top of a file. Unlimited different 
colors and unlimited different layers are available. By turning markup 
layers on and off, markups written by different commentators can 
easily be isolated and viewed separately. Markups are stored in 
vector files separate from the original file. The markup files can be 
either one single file (extension .XCM as default) or multiple files - one 
for each commentator. 

3.9.1 Markups in Multiple Files 
The first markup file has the same name as the viewed file but with 
the extension .000 or .X00. The next markup file has the extension 
.001 or X01 and so on. The maximum number of commentators, each 
with different stored markups, is 1000 or 360 depending on the 
selected extension type. 

3.9.2 Markups in a Single File 
The markup file has the same name as the viewed file but with the 
default extension .XCM. The number of commentators allowed, each 
with different stored markups, is unlimited. 

3.9.3 Markup Policy 
To avoid internal conflicts, an organization should define either a 
single or multiple markup file policy, as single markup files cannot be 
read and maintained simultaneously by different users. Administrators 
and programmers can implement advanced markup control.  

3.9.4 Compatibility with Earlier Markup Files 
The following rules apply for creating and viewing existing markups 
created in RxView and RxViewX. 

Important Markup compatibility rules for backwards compatibility: 
5. RxHighX R6 and RxHighlight R6 can read markup files created 

by RxHighlight R5, RxHighX R5, RxHighlight 97 and RxHighX 97. 
6. RxHighlight 97 or RxHighX 97 cannot read Markup files created 

in RxHighX R6 and RxHighlight R6 with markup. All users should 
therefore upgrade to the same version of the markup software. 
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7. To read markup files, both 32-bit and 16-bit RxHighlight must 
have the correct markup file extension type. These are set in the 
Options > Preferences dialog for 16-bit RxHighlight, and in the 
Comment > Preferences dialog for 32-bit version. 

8. 32-bit RxHighlight can only read markups created in 16-bit 
RxHighlight. 

9. 16-bit RxHighlight cannot read markups created or modified in 
32-bit RxHighlight. 

10. XCM markup files can only be created and viewed in 32-bit 
RxHighlight. 

11. 32-bit RxHighlight will always read XLK files, i.e. 16-bit 
RxHighlight link files. 

12. Do not rename 16-bit markup files as XCM files. 32-bit 
RxHighlight will not be able to read them. 

3.10 Document Linking 
Links are stored together with markups in the same file(s).  
You may link files to each other. In other applications this feature is 
often called “Hyper-linking”. Linking creates buttons in the viewed file, 
which are connected with other files. When you click a link button on 
the viewed file, the corresponding file is loaded. Other comments may 
also contain links to other documents. 
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Chapter 4 Viewing Features and Samples 
 
The samples demonstrate powerful features that are available using 
this application. The samples may vary depending on your installation. 

4.1 Samples folder 
The samples in this folder can be loaded by the application either 
singly or as a selection using the Open dialog. The samples 
demonstrate screen display and printing for a range of the file formats 
supported by Rasterex viewing applications. 
Samples include: 

Document formats including Word, text and Acrobat reader PDF. 
Spreadsheets including Excel 
Pictures and raster files including TIF, GIF, JPG, BMP 
Drawings including AutoCAD DWG, MicroStation DGN, other CAD 
formats and HPGL plot files.  
3D drawing files including SolidWorks, STL, IGES, ACIS/SAT, etc. 
Also Catia, Pro-E, I-DEAS and UniGraphics if the required licenses 
are installed. 

4.2 Compare folder 
The samples in this folder demonstrate a feature for comparing 
revisions of drawing files. Load the file with extension XWS to view the 
displayed differences between the two revisions. The differences are 
in the window marked (Overlay). To examine the compare dialog, 
click the dropdown button on the Open icon and select Overlay. The 
compare function is described in detail later in this manual.  

4.3 Overlay folder 
The samples in this folder demonstrate a feature for overlaying files to 
create a montage of drawing and picture files. Load the file with 
extension XWS to view an overlay of the loaded files. The overlay is in 
the window marked (Overlay). To examine the overlay dialog, click the 
dropdown button on the Open icon and select Overlay. The overlay 
function is described in detail later in this manual.  
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4.4 Markup folder 
The samples in this folder are a project demonstrating markup 
features including links to other files, text items and drawing objects.  
  

Load the file TRACER.TGA.  

Select the Push button  in the Markup toolbar.   

Click any link button  in the Markup toolbar to view an 
associated link file.  
Click the link button in the loaded file to return to your original file. 

 
Linking and Markup are described in detail later in this manual.  
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Chapter 5 Toolbar Buttons  
Toolbars may only be active for specific file types, e.g. Office 
documents, 3D drawing files, CAD files etc.  
Toolbar buttons often lead to extensive new dialogs and options. The 
dialogs are described in detail in the next chapter.  As you work with 
RxView use this chapter for a short explanation of toolbar and button 
functionality. Use the next chapter for an explanation of the file dialogs 
that appear. 

5.1 Standard Toolbar 
The Standard Toolbar holds the buttons used to operate common 
functions within RxView. 

5.1.1 Open  

 Opens a standard File Open dialog. Browse, select and open any file. 
Click the drop-down arrow beside the button to open a list box of 
previously opened files. 

5.1.2 Open Previous  

 This button will display once you have opened a file. Click to open the 
previous file, as listed in the currently selected folder. 

5.1.3 Open Next  

 This button will display once you have opened a file. Click to open the 
next file, as listed in the currently selected folder. 

5.1.4 Save As  

 This will open the Save As dialog where you can select from available 
target formats. 

5.1.5 Close  

 Close the active file. 
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5.1.6 File Explorer  

 Toggles the Folder and File Explorer windows. The Folder and File 
explorers allow you to browse and select files on your network. 

5.1.7 Workspace Bar  

 Toggles the Workspace Bar window. Refer to the next chapter for 
more information about the Workspace Bar. 

5.1.8 File Properties  

 Displays the active file properties. Size, file type etc. Press ESC to 
close the File Properties dialog. 

5.1.9 Find Text  

 Displays the Find dialog that is used to search for text in a document 
or drawing. 

5.1.10 Toggle Full Screen  

 Toggles the current file to display full-screen. While the file is 
displayed full screen the button will be displayed in the upper left 
corner. Click the button or press ESC to return to the “normal” layout. 

5.1.11 Filter Settings  

 Opens the Filter Settings dialog. This dialog enables you to inspect 
and change settings for individual filters.  

5.1.12 Edit Document  

 Starts the editing application associated with the active file, and opens 
the active file in that application.  

5.1.13 Back Link and Forward Link  

  Move to the previous or next file in the link list. 
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5.1.14 Print  

 Opens a standard Print Setup dialog.  

5.1.15 Print Preview  

 Changes the display to the Print Preview window, enabling you to see 
the image, as it will appear on paper before you print it out.  

 

5.2 View Toolbar 
5.2.1 Zoom All  

 Zooms the image to fit either the display area width or height 
depending on which dimension is reached first. 

5.2.2 Zoom 1:1  

 Zooms the image to its actual size. If the image extends beyond the 
borders of the display area, pan slider buttons will appear as required. 

5.2.3 Zoom In  

 Zooms in to the image in steps. Click the Zoom Out button to reverse 
the process. 

5.2.4 Zoom Out  

 Zooms away from the image. Click the Zoom In button to reverse the 
process. 

5.2.5 Zoom Width  

 Zooms the image such that it fits across the width of the viewing area. 
If the image is then taller than the viewing area, the top edge of the 
image will be placed at the top of the viewing area and the vertical 
scroll bar will be displayed at the right side. Use the scroll bar to view 
the parts of the image that are outside the viewing area. 
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If the height of the image is less than the height of the viewing area, 
the image will be centered vertically in the area. 

5.2.6 Zoom Height  

 Zooms the image such that it fits vertically within the height of the 
viewing area. 
If the image is then wider than the viewing area, the left edge of the 
image will be placed at the left of the viewing area and the horizontal 
scroll bar will be displayed below. Use the scroll bar to view the parts 
of the image that are outside the viewing area. 
If the width of the image is less than the width of the viewing area, the 
image will be centered horizontally in the area. 

5.2.7 Zoom Previous  

 Click this button to return to the previous zoom state. Retains 
information about the last 10 zoom states. 

5.2.8 Zoom Window  

 Zooms in to a particular area of the file and fits it to the view window. 
Click on the top-left of the area to be viewed and hold down the left 
mouse button. Drag to the selected area and release the button 

5.2.9 Pan Hand  

 Enables you to view parts of an image that are outside the window by 
grabbing the image and moving it. Hold in the left mouse button and 
drag the mouse to pan. 

5.2.10 Zoom In/Out  

 Enables you to click the left and right mouse buttons to zoom into and 
away from the file respectively. Hold in the left mouse button and drag 
the mouse to zoom in and out dynamically. 
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5.2.11 Scale To Window  

 Activate this function to tie the image size to the window size. 
Maintains the image fitted to the window as the window size changes.  

5.2.12 Toggle Angle  

 If you are viewing a raster or vector image, click this button to rotate 
the image through steps of 90°. 

5.2.13 Calibrate  

 Click this icon to initiate calibration of the active file. The process 
measures the length of a line and enables the length to be converted 
to a measurement that will then apply to the scale in the active file.  
Click with the left mouse button on 2 points a known distance apart 
and the Calibration dialog is presented.  

5.2.14 Measure  

 Click the icon to initiate a measurement on the active file. The process 
measures the length of a line, the angle between 2 lines, or the area 
enclosed by multiple lines, inside the viewed file. Click with the left 
mouse button on 2 or more points that can include an area. Press 
ESC to terminate measurement and the Measurement Statistics 
dialog is presented. 

5.2.15 Toggle Color  

 Toggles the background color of the active file through the four 
available options. White, Black, Gray and Custom. 
Choose your own custom color in the Tools > Options dialog.  
Note  Only the background of the active file is changed. 

5.2.16 Magnifying Glass  

 Activates the Magnifying Glass function, which magnifies a part of the 
active file and displays the enlarged area in front of the file. 
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5.2.17 Magnifying Window  

 Activates the Magnifying Window function, which magnifies the part of 
the active file around the cursor. 

5.2.18 Bird’s Eye View  

 Activates the Bird’s Eye View function. This function provides an 
overview of the file, and allows you to pan around and select areas to 
zoom. See later in this manual for further details. 

5.2.19 Compare and Overlay 

 Activates the Compare and Overlay dialog. See later in this manual 
for further details. 

5.2.20 Select overlay 

 Allow you to select an overlay and move/scale it using the mouse. 

5.2.21 Overlay properties. 

 Opens a dialog displaying the properties of the currently selected 
overlay. 

 

5.3 Office Tools Toolbar 
5.3.1 Page Down  

 Page down through multi-page files. The button is grayed when the 
last page is reached. The button is grayed on single page files. 

5.3.2 Page Up  

 Page up through multi-page files. The button is grayed when the first 
page is reached. The button is grayed on single page files. 
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5.3.3 Page List Box 

  Indicates the current page being displayed.  

5.3.4 One Page View  

 Displays the current page only. 

5.3.5 Thumbnail View  
 Displays thumbnail images of all the pages in the file window. 

5.3.6 Page and Thumbnails View  
 Displays a combination of thumbnail images and the current page in 

the file window.  

5.3.7 Zoom List Box 

  Indicates the current zoom of the active file.  

5.3.8 Zoom 100%  

 Forces the zoom factor to 100% for the active file. 

5.3.9 Gridlines  

 Toggles spreadsheet gridlines for displays and printing.  

 

5.4 CAD Tools Toolbar 
5.4.1 Previous View and Next View  

  Click this button to move to the next or previous view in the file. The 
button is grayed out if there are no next or previous views in the file. 
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5.4.2 Previous Layout and Next Layout 

  Click this button to move to the next or previous layout in the file. The 
button is grayed out if there are no next or previous layouts in the file. 

5.4.3 Toggle Block Mode 

 This button toggles the Block Utilities mode on and off. 

5.4.4 Previous Block and Next Block 

  Click this button to move to the next or previous block in the file. The 
button is grayed out until the next or previous block button has been 
clicked or if there are no next or previous blocks in the list. 

 

5.4.5 List Attributes for Selected Block 

 Click this button to open a dialog with a list of attributes for the 
selected block. The button will be grayed out if there are no attributes. 

5.4.6 Search Attributes 

 Click this button to search for a particular attribute. The button will be 
grayed out if there are no attributes. 
5.4.7 Pen Table Settings  

 Click this button to open the Pen Table Settings dialog, enabling you 
to set line widths etc. for vector files. 

5.4.8 Vector Layers  
 Click this button to open the Vector Layer Control dialog, enabling you 

to select vector drawing layers for viewing and printing.  

5.4.9 Entity information 

 When active you can click on vectors and get information about the 
selected vector. 
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5.5 Address Toolbar 
The Address box contains the paths of files recently opened in 
RxView, and your current location in the file explorer. As you move 
through the archives using the file explorer, the path given in the 
address box will be updated. The toolbar holds two buttons: 

 Delete Item - Deletes the selected item from the pull-down list. 

 Delete All Items - Deletes all the items in the pull-down list. Note  
Only the references are deleted from the list, the files are not deleted 
from their archive folders. 

 

5.6 3D Toolbar 
The buttons on this toolbar are only active if the active file is a 3D 
drawing model. 
 

5.6.1 Rotate  

 Toggles rotate state to turn the image to a specific view. Hold down, 
Ctrl, Alt or Shift keys when rotating to lock the X, Y or Z-axes. 

5.6.2 Spin  

 Enables you to set the image spinning. Hold down, Ctrl, Alt or Shift 
keys when spinning to lock onto the X, Y or Z-axes. 

5.6.3 Wireframe  

 Removes the “fill” from the image, leaving just the framework. 

5.6.4 Perspective  

 Toggles the image between isometric and perspective.  
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5.6.5 Reset 3D Model  

 Resets the image to its load state, as it looked when first opened. 

5.6.6 Enable Cross-Section  

 Toggle this button to activate and deactivate the sectioning function. 
You can set up the cutting planes while keeping the entire image, then 
toggle this button to view the image with and without the parts that you 
wish to cut away. 

5.6.7 Show Cross-Section Plane  

 Toggle this button to show and hide the cutting planes used by the 
sectioning function. 

5.6.8 Cross-Section Clipping 

 This opens a Section Clipping dialog with sliders enabling you to set 
up to six clipping planes. Each plane can be rotated around three 
axes, and may be inverted. 

5.6.9 Set Cross-Section  

 This option enables you to cut the object using a single straight line, 
as if with a knife. You can then use the rotation and invert functions to 
move the object to achieve the desired view. 

5.6.10 Invert Cross-Section  

 This function inverts the visible cross section, showing the parts you 
have cut away and hiding the parts 

5.6.11 Material and light  

 This open a material and light dialog where you can change the color 
and reflection properties of the rendered model. 
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Chapter 6 Configuration and Customization 
Tools menu item in RxView offers customization options for many 
smart features. This chapter describes the available dialogs and how 
to personalize your settings by creating your own toolbars, short-cut 
keys, etc. 
RxView has extensive configuration settings including snap options, 
measurements, file filters, pen tables, and plugin management.  

6.1 Setting Up the RxView Options 
Select the Tools > Options menu item or click Options in the active file 
right-click menu to open the Options dialog shown below. 

6.1.1 General Tab 

 
Figure 3  Options dialog General tab 
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• Magnification factor – Is the zoom factor used for the magnifying 
glass and magnifying window function. See later details. 

• Address history size – The maximum number of recently 
opened files displayed in the Address list box. 

• Window menu contains – The maximum number of files to be 
listed in the Window > Windows menu list.  

• Recent file list contains – Is the number of recently opened files 
listed in the File menu. 

• Snap tolerance – Is the range within which the snap function will 
move the cursor to a node. The snap function is described later. 

• Custom color picker – Enables you to select or create your own 
background color to be used in the Toggle Background Color list.  

• Write settings to DEFAULT user registry key – an option for 
users without administrator permission. 

6.1.2 QuickView Tab 
QuickView files are created for each original file when selected in the 
explorer. Use the QuickViews and/or thumbnail images to identify the 
file before opening. QuickView files may be saved using one of 
several methods. Use the options on this tab to set the save 
preferences for the QuickView files. These settings will apply for all 
files opened after the settings are made. 
• Use embedded preview if available – Some file types may have 

a thumbnail view embedded in the file. 
• Database storage 

− None – QuickViews are not stored but regenerated each 
time the file is accessed. This method can lead to delays 
while the QuickViews are created. 

− Single database file – As the QV files are created, they are 
stored in a specified folder as a database file. The QV files 
are then available for immediate use the next time you 
access the originals so delays are avoided. Set the required 
folder in the Local or Common folder options. 
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− Individual QuickView files – Each QV database file is 
stored in the same folder as the original file. The QV files are 
available for immediate use the next time you access the 
originals  

 
Figure 4  Options dialog QuickView tab 

• Common folder – All the QV files created will be stored in a 
common folder. Check the option, and type in the path or use the 
browse function to specify the folder. This option will be grayed out 
if it is not applicable. 

• Background Color. Select the background color to use for the 
QuickView. 

• High Resolution Quickviews. Select this option if you want 
QuickView with high resolution. High resolution is 280x220 pixels. 
Standard is 140x120. 

• Show QuickViews in File Open dialog. If you turn this on, a 
QuickView of the currently selected file will be displayed in the file 
open dialog. 
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6.1.3 Advanced Tab 
Check the applicable boxes to activate the function: uncheck the 
boxes to deactivate. 

 
Figure 5  Options dialog Advanced tab 

Display Operations 
• CAD style zoom window – Allows the zoom feature to operate in 

the same way as the corresponding feature in the AutoCAD 
program. 

• Enable Wheel button Zoom and Pan – Check this option to 
enable the use of the mouse wheel for zoom and pan. 

• Page layout mode – Check this option to display the drawing and 
document extent as a page. 

• Show axes for 3D documents – Check this option to display the 
3D axes in the lower left corner of the window for 3D images. 

• Remove hidden lines – Check this option to remove lines (e.g. In 
Wire-frame view) that would normally be hidden by other surfaces. 
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• Show image extents – Check this option to display the 
boundaries of the displayed image. 

• Fill drawing polygons – Displays vector polygons filled. Do not 
use this option if you require a faster display. 

• Mono drawing display – Will display vector files, e.g. DWG, 
DGN, in monochrome rather than color. 

Spreadsheet Options 
• Display gridlines - Uncheck this option if you do not want to 

display and print the grid lines in a spreadsheet. 
Thumbnail Options 
• Thumbnail color – Set the background color for multipage 

thumbnails. 
Raster Options 
Scaling (to display an image perfectly will require a lot of processing, 
so displaying is a compromise between the accuracy of the display 
and the time taken to calculate the image.) 
• Normal – Raster scaling is the fastest method of displaying during 

zooming. Some black areas may disappear during zooming. 
• Scale to gray – Scaling is the slowest method of displaying 

during zooming, but it gives the best display results. If you have 
problems reading, for example TIF files, use this option to improve 
clarity. 

• Preserve black – Scaling is the next fastest display method. 
Some black areas may disappear during zooming. 

Use Halftoning for color images to display color images sharply 
regardless of zoom factor. 
Document Options 
• Zoom 100% – Check this option if you wish to display the present 

page in the default Window’s document scaling (1440 twips). 
Depending on the size of your screen this option may create scroll 
bars in the document window.  

• Retain page view – Check this option if you wish to keep the 
current zoom setting as you move to a different page in the 
document file. 
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• Zoom all – Check this option if you wish to zoom the current page 
to the maximum possible within the window as you move to a 
different page in the document file. 

• Zoom width - Check this option if you wish to zoom the current 
page to the width of the window as you move to a different page in 
the document file. 

CAD Options 
• Show warning for missing XRef files – AutoCAD and 

MicroStation use XRefs. 
• Show warning for missing font files – AutoCAD and 

MicroStation use font files.  
Measurement / Calibrate Options 
• Enable ortho – Restricts the measurement and calibration 

functions to orthogonal (vertical or horizontal) movement only. This 
function may be toggled using the F8 key. See later in the manual 
for further details. 

• Display measurement dialog box – Allows the Measurement 
Statistics dialog box to display when you press ESC key after 
using the left mouse button to perform a measurement. See later in 
the manual for further details. 

Snap Options 
• Enable Snap – Switches on the Snap function for measuring. The 

cursor snaps to defined points on a line as it moves within range. 
This function may be toggled using the F9 key. See later in the 
manual for further details. 

− Nearest – Snaps to the nearest line. 
− End Point – Snaps to the nearest end-point on the nearest 

line. 
− Middle Point – Snaps to the mid-point of the nearest line. 
− Center – Snaps to the center of a circle or arc. 
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Magnifying Glass Shape 
• Rectangular – Gives a rectangular magnifying glass frame. See 

later in the manual for further details. 
• Circular – Gives a circular magnifying glass frame. See later in 

the manual for further details. 
Default Zoom Function 
• None – No zoom function is active when the application is started. 
• Zoom Window – Zoom Window function is active when the 

application is started. 
• Pan – Pan function is active when the application is started. 
• Zoom In/Out – Zoom In/Out function is active when the 

application is started. 
Printer Settings 
• Print hybrid files as bitmap – Some files are not reproduced 

correctly on paper if rotated. Turn this option on if text become 
inverted. 

Application Settings 
• SDI behavior – (Single Document Interface) Check this option if 

you wish to restrict RxView to having only one document open at a 
time. RxView will then automatically close the open document if 
another is opened. 

• Show Windows Tabs – Tabs for each open file is displayed to 
allow fast selection of open files. 

• Use local copy of opened file - RxView makes a copy of the 
active file so that the file is not locked for other users. The copy is 
deleted automatically when the file is closed.  

• Dynamic network licensing – Allow users to dynamically acquire 
a license for RxHighlight when needed, otherwise an RxView 
license is used.  

• Always save markup on exit – If checked, RxHighlight will save 
any markups created or changed without prompting the user when 
closing the application. 

• Keep RxView always on top – keeps RxView always in the front 
on your display. 
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• Show ZIP Archive dialog – Display the ZIP Archive dialog when 
opening zip files, allowing the user to select which files in the 
archive to open. 

• Allow only one running instance of RxView – If checked you 
can only run one instance of RxView on the same computer. 

Click Apply to apply changes and keep the dialog open, click OK to 
apply the changes and close the dialog, and click Cancel to cancel 
any changes and close the dialog. 
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6.1.4 File Types Tab 
To speed up searches and loading, instruct RxView to ignore 
specified file types by adding file type extensions to the list. 

 
Figure 6  Options dialog File Types tab 

To add a file type to the list, type the appropriate file extension into the 
Add to list box and click Add. 
To remove a file type from the list, select the file type in the list and 
click Remove. 
Click Apply to apply changes and keep the dialog open, click OK to 
apply the changes and close the dialog, and click Cancel to cancel 
any changes and close the dialog. 
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6.2 The Customize Dialog 
Select the Tools > Customize menu item or click Customize in the 
toolbar right-click menu to open the Customize dialog shown below. 
Click on the tab for the function you wish to customize. 

6.2.1 Commands 
On this tab you can insert functions into toolbars, and menus. 
When creating a new toolbar or menu item, find the required 
command in the Commands list and drag-and-drop it into the toolbar 
or menu as appropriate. See also paragraph 6.2.2.2 for details. 

 
Figure 7  Customize dialog > Toolbars tab 

6.2.1.1 Creating a New Menu 
1. Select New Menu from the Categories list. 
2. Click on the New Menu item in the Commands list, and drag-and-

drop it into the appropriate place in the menu. 
The menu item will be located at the horizontal black line. 

3. Select the new menu item and right-click on it, then click on 
Appearance. 
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The Button Appearance dialog opens. 
4. In the Text line, type in the name you wish to use for the menu. 
5. Click OK to close the dialog. 
6. Drag-and-drop the required commands from the Commands list 

into the new submenu. 
7. On completion, click OK. 
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6.2.2 Toolbars 
Use the Tools > Customize > Toolbars dialog to decide which toolbars 
are to be displayed, setup existing toolbars, and create new ones. 

6.2.2.1 Displaying and Hiding Toolbars 
1. In the Toolbars field, check the toolbars you wish to display and 

uncheck those you do not need. 

 
Figure 8  Customize dialog > Toolbars tab 

2. Set the options as required. 
• Show Text labels – Enables text labels to appear beneath each 

button. 
Click OK to apply any changes and close the dialog, click Cancel to 
close the dialog without applying changes, or click Apply to apply the 
changes and leave the dialog open. 

6.2.2.2 Creating Your Own Toolbars 
1. Open the Customize dialog and click the Toolbar icon. 
2. Click the New Toolbar button. 
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A new toolbar is created in the workspace and in the Toolbars 
list. 

3. Type in a name for your new toolbar. 
4. Click on the Commands icon in the Customize list. 
5. In the Commands window, find the commands that you want to 

have in your new toolbar, and drag-and-drop them into the 
toolbar. 
The new buttons will be positioned at the black cursor. 

Note  While the Customize dialog is open you can reposition the 
buttons in any toolbar or menu. 
6. Set the options as required. 
Note  All the options operate on all the toolbars and the menu bar. I.e. 
you cannot set options for individual toolbars. 
7. On completion, click OK to close the Customize dialog. 
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6.2.2.3 Changing a Button Icon 
The appearance of individual buttons on the various toolbars can be 
changed. 
1. Open the Commands dialog 
2. Go to the toolbar button you wish to change and left-click on it to 

select it. 
The button is surrounded by a gray rectangle. 

3. Right-click on the button. 
4. In the drop-down menu that appears, click Button Appearance. 
5. The Button Appearance dialog opens. 

 
Figure 9  Button Appearance dialog 

6. Select the appropriate image for the icon from the Images 
window, and select other options as required. 

7. On completion click OK to return to the Customize dialog. 

Click OK to close the Button Appearance dialog. 
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6.2.3 Keyboard 
On the keyboard tab you can select and change the RxView 
accelerator keys. An accelerator key can be allocated to any function 
included in a menu for example, CTRL + O is the Windows shortcut 
key to initiate the File Open function. Accelerator keys are used to 
speed up access to commonly used functions. To allocate or edit an 
accelerator key, proceed as follows: 
  
1. Open the Customize dialog and click on the Keyboard tab. 
The Keyboard tab shown below is activated. 
 
 
 

 
Figure 10  Customize dialog > Menu tab 

2. You can limit the accelerator to apply only to a certain menu set 
or all menu sets by choosing Default from the Set Accelerator for: 
drop down list. 

3. Select Category, and then choose the command you whish to set 
an accelerator key for from the Commands list. 

4. The accelerator key if any is displayed in the Current Keys field. 
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5. Delete existing shortcut keys as required by selecting them in the 
Current Keys field and click Remove or Reset All. 

6. Set the cursor in the Press New Shortcut Key: field, then enter 
the keyboard keys that you wish to use to activate the selected 
function. 

7. Click Assign to copy the shortcut key sequence to the Current 
Keys: field. 

8. The new accelerator keys are immediately applied when you 
close the dialog. 

 
Examples 
For document and multipage raster files: 
• Ctrl-Home go to first page 
• Ctrl-End  go to last page 
• Ctrl-PgDown go to next page 
• Ctrl-PgUp go to previous page 
 
 

6.2.4 Menu 
On the menu tab you can select and change the RxView menus. 
Select the menu set from the “Show Menus for:” list. Then you can 
modify the menu by selecting it with the mouse. You can add and 
remove menu items and modify the appearance of menu items by 
right clicking on it. 
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Figure 11  Customize dialog > Menu tab 

6.2.4.1 Context menus 
Bring up the various context menus for modification by selecting it 
from the “Select context menu:” list. 
You can reset a context menu to its original state by applying the 
Reset button. 

6.2.4.2 Other options 
Menu animations – You can choose to let menus appear in different 
ways select the animation you want to use from the list. 
Menu Shadows – Check this options if you want menus to appear 
with shadows. 
 

6.2.4.3 Deleting a Menu Item 
Delete a menu item as follows: 
With the Tools > Customize > Commands dialog open: 
• Drag the superfluous menu item out of the menu and drop it. 
• Right click on the menu item and then click Delete. 
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6.2.5 Options 
On the options tab you can set some general options for toolbars and 
menus. 

 
Figure 12  Customize dialog > Options tab 

 
Show Screen Tips on toolbars – Enables tool tip text labels to 
appear when moving the mouse over a button. 
Show shortcut keys in Screen Tips – Show shortcut keys for the 
selected function in tool tip text label. 
Large Icons Tips – Select if you want normal sized or large sized 
buttons on the toolbars. 
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6.3  Plugin Manager 
RxView uses plugins to extend functionality, add new features, 
activate and deactivate functions using dialogs etc. Plugins are 
registered during installation and listed in the Plugin Manager dialog.  
Select the Tools > Plugin Manager menu item. You can load, unload, 
enable and disable plugins via this dialog. The plugins’ names and 
their current states are listed, and the version and a short description 
are displayed for the selected plugin. Plugin states are saved in the 
registry when RxView is closed, and will be restored when the next 
RxView session is started. Restart RxView for changes to be 
implemented. Plugins are described in separate documentation. 

 
Figure 13  Plugin Manager dialog 

To run a plugin: 
1. Select the required plugin from the list. A description of the plugin 

and its version appear in the fields below the list. 
2. Check the Loaded / Unloaded box to load the plugin. Once the 

plugin is loaded, you can enable or disable it as required. 
3. Check the Enabled / Disabled box to enable the plugin. 
4. Click OK to input the settings and close the dialog, or click 

Cancel to close the dialog without inputting the settings. 
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6.4 Configuring Toolbars and the Menu Bar 
6.4.1 Resizing Toolbars 
The toolbars can be resized as required. 
• Place the cursor on the bar’s frame then click and hold the left 

mouse button and drag the frame. Release the mouse button when 
the bar is the desired size. 

6.4.2 Repositioning Toolbars and the Menu Bar 
The toolbars and menu bar can be positioned as required on the 
screen. 
• To move a bar if it is docked, place the cursor on the bar’s grip 

(the parallel vertical lines at the left end of the toolbar if these are 
shown, or one of the spacer bars located between some of the 
buttons), or in any free space in the menu, click and hold the left 
mouse button and drag the bar to the desired location on the 
screen. 

• To move a bar if it is undocked (a separate window in the 
workspace), place the cursor in the bar’s title bar, click and hold 
the left mouse button and drag the bar. Release the mouse button 
when the bar is in the desired position on the screen. 

6.4.3 Showing and Hiding the Toolbars 
6.4.3.1 Via the File Workspace Right-click Menu 
Place the cursor in a free area of the file workspace (not on an open 
file) or in any toolbar, the menu bar or the title bar, and click the right 
mouse button to display the pull-down menu. The toolbars are listed in 
the center section of the menu. Check the required toolbars and 
uncheck those that are not required.  
Note  The right-click menu closes after each selection. 

 
 

62



6.4.3.2 Via the Customize Menu 
1. Select the Tools > Customize menu item, or, place the cursor in a 

free area of the file workspace and click the right mouse button, 
then click on the Customize option. 

2. Click the Toolbars icon to switch to the Customize Toolbars 
dialog. 

3. In the Toolbars field, check the toolbars you wish to display and 
uncheck those you do not need. 
Set the options as required. 

4. Click OK to accept the settings and close the dialog. 
For further details on the Tools > Customize > Toolbars dialog, see 
earlier in this chapter.  
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6.5 Configuring the Folder Explorer 
The folder explorer can be positioned as required on the screen. 
• To move the explorer if it is docked, place the cursor on the grip 

(the explorer’s title bar), click and hold the left mouse button and 
drag the explorer to the desired location on the screen. 

• To move the explorer if it is undocked (a separate window in the 
workspace), place the cursor in the title bar, click and hold the left 
mouse button and drag the bar. Release the mouse button when 
the bar is in the desired position on the screen. 

• To resize the explorer, place the cursor over an edge or a corner, 
click and hold the left mouse button and drag to the desired size. 

• To toggle the explorer on or off, access the file workspace right-
click menu or the folder explorer right-click menu. You can also 
click the File Explorer button.   

6.6 Configuring File Explorer  
The file explorer and Document Properties bar can display file 
information in columns. These columns can be toggled on and off, 
moved, resized, and the files sorted. 

6.6.1 Showing and Hiding Columns 
To show or hide a column: 
1. Place the cursor anywhere in the column header bar and click 

the right mouse button. 
A submenu of the column options is displayed. 

2. Check those columns you wish to display and uncheck those that 
you do not require. 

6.6.2 Moving Columns 
To move a column: 
1. Place the cursor on the column header button you wish to move, 

then click and hold the left mouse button. 
2. Drag the button to the desired location in the bar. 

As you drag the cursor, the nearest “space” between the buttons 
turns blue to indicate where the button will be located. 
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6.6.3 Sorting File Details 
The files listed can be sorted by name, size, file type, modification 
date and attributes, in either direction (up or down). 
• Click on the appropriate column button to select the desired sort 

method. 
• Click the same button again to toggle the direction (note the arrow 

indicating the sort direction). 
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Chapter 7 RxView Dialogs  

7.1 Filter Settings 
The Filter Settings dialog holds information about the various file filters 
and their setup options. Click the Filter Settings button  on the 
View toolbar or select the Tools > Filter Settings menu item. 

7.1.1 Information Tab 
When you open the Filter Settings dialog, you are presented first with 
a list of the filters and the Information tab. Pan to and select the filter 
to set up. The Information tab shows types of files the selected filter 
supports, the file group (text, vector, raster etc.), the version and 
name of the filter, and whether the filter is currently licensed.  

 
Figure 14  Filter Settings dialog, Information tab 
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• Associate files of this type with RxView – Check this box to 
associate files that use the selected filter with RxView. Thereafter, 
when you double-click on a file with the same extension, RxView 
will open and the file will be loaded.  

Note  This function does not work in the trial version of RxView R6. 
• Open with embedded viewer – By checking this option you can 

tell RxView to open and use a viewer embedded in the file instead 
of using RxView. Then when you open a file of the selected format, 
the embedded viewer will open as a window in the RxView 
workspace, with the file opened within that viewer. 

Note  This may improve viewing capabilities for some file formats, but 
the markup function will not work within “external” viewers. 
• Properties – Opens the Filter Properties dialog, see earlier in this 

chapter. 
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7.1.2 Options Tab 
The Options tab enables you to set some default settings for the 
selected filter. 

 
Figure 15  Filter Settings dialog, Options tab 

• Background color – Sets the default background color to be 
used for files supported by the selected filter. See Setting the 
Background Color later in this chapter. 

• Rotation – If a large percentage of the files supported by this filter 
need to be rotated before opening (for example they may have 
been scanned at a different angle), you can preset a rotation angle 
here. See Rotating Images later in this manual. 

• Priority – Give the filter a priority. Filters with a higher priority will 
be interrogated first when RxView is attempting to recognize an 
unidentified file type. Use this option to prioritize a filter. 
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• Wildcard – On installation, the various filters are installed with a 
wildcard matching the normal file extension, but you may add or 
use other extensions. Write optional wildcards in this field for 
selected filters. The File Open dialog box then uses these 
wildcards to search for matching file types in the selected folder. 
Multiple file extensions for a filter can be used. Each wildcard must 
be separated by a semicolon, for example, *.TXT;*.ASC;*.DAT. 

• Edit Application – RxView is a viewing application. If you wish to 
edit the actual image file, you will need to start an editing 
application suitable for that image type. Use this field and/or the 
browse button to register the application for the image type. 

• Keep drawing colors – Normally, if a color on the image is very 
close to the background color (for example a light gray line on a 
white background), RxView will invert the color to obtain a better 
contrast and make the object more visible. If you check this box, 
RxView will keep the original colors but you may then risk losing 
details from the image. 

• Disable this filter – Check this box if you know you will not need 
to use a particular filter. This will prevent the filter being used. The 
box will remain checked until you uncheck it. 
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7.1.3 Measure Tab 
This tab is used to set up the scale of the image and calibrate it to 
enable measurements to be made on the screen. 

 
Figure 16 Filter Settings dialog, Measure tab 

• Type – Set the type of units required for files associated with this 
filter. Choose between System, Imperial, Metric and User. 

− System – No units of measurement are specified for this 
filter, so RxView will use the default units specified by the 
file. 

− Imperial – Use imperial units for the filter. 
− Metric – Use metric units. 
− Custom – Define your own units for the filter. Name the 

units 
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• Decimal Precision – Must be input for the selected units. The 
decimals are shown in the X and Y coordinate fields located in the 
right end of the status bar when a drawing is loaded. 
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• Resolution – Some files have a resolution in dots per inch 
included in the file. 

Depending on the type of units selected, the resolution will be 
shown in dots per inch, dots per mm or the user-defined unit 
selected for the filter. 
AutoCAD files do not have absolute units of measurement, so for 
these files you must decide the length a unit is to have. The 
easiest way to do this is to use Calibrate. 

• Calibrate allows you to set the scale of a drawing. Refer to 
paragraph 10.2 on page 126 for further details. 

• When available use UPI from file – Some file types contain UPI 
(Units per Inch) information. Check this box if you want to use UPI 
information in your measurements. 

• Custom unit name – If you wish to define your own unit of 
measurement, give it a name here. 

• mm per custom unit – Define how large, in mm, you wish your 
units to be. 
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7.1.4 Pen Table Tab 
This tab is used to select a pen table file (.RPT) if one is available. 

You can create pen table files via the Pen Table Settings button  
in the CAD Tools toolbar. See Pen Table Dialog later in this chapter 
for further details. The tab is grayed out if it is not applicable to the 
selected filter. 

 
Figure 17 Filter Settings dialog, Pen Table tab 

• Auto load pen table settings – Check this box to enable the 
Choose Pen Table File (*.RPT file) selection dialog. When the box 
is checked and a pen table file is selected, that pen table file will be 
used automatically when a file using the selected filter is opened. 

 
 

73



7.1.5 Filter Properties  
The filters included with RxView enable you to see the various files in 
the workspace. You can configure each filter separately, such that the 
files associated with each filter are presented in a way suited to your 
requirements. RxView has two filter configuration dialogs: Filter Setup 
described in the previous sections and Filter Properties. 
The Filter Properties dialog opens at the ACAD tab. 
• Select Tools > Filter Properties to open the dialog shown below. 

7.1.5.1 The AutoCAD Tab 

 
Figure 18 Filter Properties dialog, AutoCAD tab 

This tab enables you to set display and font options for files created 
using AutoCAD. 
The options are as follows: 
• PS LT Scale – Controls paper space line-type scaling. Select the 

required option. 
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• Load ACIS Models – Check this box if you wish to allow the filter 
to load 3D ACIS models. Note that these models may take a 
considerable time to load. 

• Hide Frozen Layers – Check this box if you wish to hide layers 
that have been frozen. 

• Load Attribute Info – Check this box if you wish to search for 
and list block attributes. 

• Recalculate Extents – If the drawing’s actual extents are not 
given in the header, use this option to find the extents and redraw 
the display. 

• Zoom Resolution – If the drawing is very large and you need see 
clearly the details in small section of it you can increase the Zoom 
Resolution factor to ensure that the resolution on high 
magnifications is sufficient to see the details clearly. This will 
reduce performance for AutoCAD files. 

• Use AutoCAD Fonts – Check this box if you wish to allow the 
filter to use AutoCAD fonts. 

• Font Folder – If you wish RxView to use AutoCAD fonts, input the 
path to the folder containing the font files. 

• Default Font – Input the name of the font file you wish to use as 
default. Check the Use Default Font box if you wish to restrict 
RxView to using that particular font. 

• XRef Folders – Type in folders where the filter is to search for 
externally referenced drawings. You may specify several folders 
separated by “ ; “ e.g. C:\XREFS; C:\AUTOCAD etc. 

Note  Layouts are described later in the manual. 
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7.1.5.2 The Binary Tab 

 
Figure 19 Filter Properties dialog, Binary tab 

This tab enables you to set the default font and the default paper size 
for each page for a binary file. 
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7.1.5.3 The CalComp Tab 

 
Figure 20 Filter Properties dialog, CalComp tab 

A file may be set up to print correctly on a specified CalComp plotter. 
The Rasterex filter must then be configured to interpret the file 
settings such that the file can be printed to a different unit. This tab 
enables you to configure the settings. 
• Auto Detect Plotter Settings – Check this box if you want the 

filter to search for the required settings automatically. 
• Sync Character – Set the number of synchronization characters 

to be used. 
• Extra Sync Character – Input a value here if an additional sync. 

character is to be used. 
• Use Double Sync Character – Check this box if both the above 

sync. characters are to be used. 
• End Of Block Character – Input the appropriate end-of-block 

character. 
• Use Checksum – Check this box if a checksum is used. 
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7.1.5.4 The MicroStation Tab 

 
Figure 21 Filter Properties dialog, MicroStation tab 

This tab enables you to set the path to the required font resource file 
and reference file folders for MicroStation files. 
• Use MicroStation Fonts – Check this box to instruct the filter to 

use the font defined by the MicroStation file. 
• Font Resource File pathname – If you check the above box, 

type in the path of the required font file or browse to it. 
• Reference File Folders – A DGN file can include references to 

other files. Type in the path to the appropriate folder or browse to 
the file. Multiple file paths can be entered; separate them with ;. All 
paths will be searched. 

• Add .DGN Extension to Reference Files – Add the DGN file 
extension to reference files to simplify file searches. 

• Load Raster Reference Files – You can deselect this option to 
reduce the time taken to load a hybrid file. 
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• 2D Display List – Check to force a drawing to be displayed as a 
2D image even though it may originally be a 3D drawing.  

7.1.5.5 The Gerber Tab 

 
Figure 22 Filter Properties dialog, Gerber tab 

This tab enables you to set the default units and the aperture number, 
shape and size for Gerber files. 
• File Units – Select the type of units to be used for the file. 
• Incremental Coordinates – Check this box if the file uses 

incremental coordinates, otherwise absolute coordinates will be 
used. 

• Aperture Number – The number of the aperture you wish to 
show/change. 

• Shape – The shape of the aperture. 
• Width – The size of the aperture along the X-axis, given in the file 

units selected. 
• Height – The size of the aperture along the Y-axis, given in the 

file units selected. 
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• Hole Size - If an object contains a hole, for example a do-nut, this 
defines the size of the hole. 

Note  Some of the parameters depend on the shape selected. 
• Next – Show the next aperture. 
• Prev – Show the previous aperture. 
• Goto – Opens an “aperture selection” dialog where you can enter 

the aperture you wish to show/change. 
• Aperture Units - Unit specified for a particular aperture. 

7.1.5.6 The Text Tab 

 
Figure 23 Filter Properties dialog, Text tab 

This tab enables you to set the default font and other parameters for 
text files. 
• Name – Use this list box to set the default font to be used when 

displaying text files. 
• Style – Use this list box to set the default font style to be used 

when displaying text files. 
• Size – Use this list box to set the default font size to be used 

when displaying text files. 
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• Page Setup – Setup the page layout for printing. Use either 
default printer settings or select a different paper size. 

• Word Wrap – Check this box if you want words that extend 
beyond the end of the line to wrap to the next line. 

7.1.5.7 The VC5 Tab 

 
Figure 24 Filter Properties dialog, VC5 tab 

This tab enables you to set the location of AutoCAD font files so 
RxView can find them when necessary. If the AutoCAD font files are 
not found, text included in the drawing will not be displayed. 
In all cases: 
Click OK to accept the settings and close the dialog, click Apply to 
accept the settings and keep the dialog open, or click Cancel to close 
the dialog without implementing any changes. 

 
 

81



7.2 Pen Table Dialog 
Typically in a vector file, lines have the same on-screen thickness but 
different colors. Colors can be interpreted to create printed output with 
different line thickness, colors and styles. Use the Pen Table dialog to 
define how you want a particular line color on the file to be printed or 
plotted. Change a single line or multiple lines by using standard 
Windows techniques to select them in the table then set the options 
as required. 

To open the Pen Table dialog, click the Pen Table button  or go to 
the Print dialog and click the Options button then select the Pen Table 
tab. 

 
Figure 25 Pen Table Settings dialog 

• Check the Use Pen Table box if you wish to use the Pen Table 
function. The other options then become active. 

• Scale – Select Scaled if when you resize a drawing file you want 
the line widths to follow the scale of the drawing. Unscaled keeps 
the line widths constant irrespective of the scale of the drawing. 
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• Units – Select the units of measurement, metric (mm) or imperial 
(inches), you wish to use when defining line widths. 

• Width – Set the desired printed width for the selected lines in the 
units defined in Units above. –1 indicates that no width has been 
defined for that pen. 

• Style – Set the desired printed line style for the selected lines (full, 
dotted, dashed etc.). Default indicates that no line style has been 
defined for that pen. 

• Color – Set the desired printed color for the selected lines. 
• Change – Click to apply the changes to the file. 
• Default - Click to return to the default settings. 
• Load – Click to load a previously saved pen table (*.RPT) file. A 

Load Pen Table dialog opens to enable you to find and select the 
desired file. 

• Save – Once you have made the desired changes to the pen 
table, save your table as an .RPT file so you can reuse the 
settings. A Save Pen Table dialog opens enabling you to name the 
file and place it in the appropriate folder. 

• OK – Apply the changes and close the dialog. 
• Cancel – Cancel the changes and close the dialog. 
• Help – Click to obtain context-sensitive help. 
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7.3 File Properties Dialog 
Click the File Properties  button to open the File Information dialog.  
 

 
Figure 26 File Properties dialog 

• File Type – The type of file, e.g. BMP, TIF, JPEG etc. 
• Local Copy – Is the file copied locally? 
• Temp Folder – Temporary folder for Local Copy files. 
• Temp Name – Temporary filename for the Local Copy file. 
• File Path – The full path to the file. 
• File Name – The full name and extension of the file. 
• Size – The file’s size. 
• Image Width – The width of the image in the units defined for the 

file. This may be “pixels” in the case of raster files, “drawing units” 
for vector files etc. The value and units are defined when the file is 
created and are not affected by image calibration, filter settings, or 
by the zoom factor. 

• Image Height – The height of the image in the units defined for 
the file. See Image Width above. 
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• Image Depth – For 3D images, the depth of the image in the units 
defined for the file. See Image Width above. 

• Compression – The type of file compression used. 
• DPI – Dots per inch, the resolution of the file. 
• Scaling – An internal factor for RimEngine relating the screen 

coordinate system with the file’s internal information. 
• X-Offset – Information retrieved from file header. 
• Y-Offset – Information retrieved from file header. 
• No. of Views – in vector CAD files 
• No. of Pages – in multipage documents, PowerPoint 

presentations 
• No. of Sheets – in spreadsheets 
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7.4 File Resources Dialog 
The File Resources dialog shows any externally referenced resources 
in the current document, whether the resource is found, the resource 
name and the resource path used. 
 

 
Figure 27 File Resources dialog 
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7.5 Find specified text dialog 
Click on the Find button  on the Standard toolbar to open the Find 
dialog. 

 
Figure 28 Find text dialog 

This dialog enables you to search for text in documents and drawings. 
The located text will be highlighted. You can use the Match Word and 
Match Case options if you want to find only whole words or words with 
a specific mixture of upper and lower case characters. 

7.6 Vector Layer Control 
Click the Layers button  on the CAD Tools toolbar to open the 
Vector Layer Control dialog. 
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Figure 29 Vector Layer Control dialog 

This dialog enables you to turn on and off selected layers in a multi-
layer file. Using standard Windows selection techniques, select in the 
Number column the layers you wish to toggle. 
• OK – Applies the changes and closes the dialog. 
• Cancel - Cancels the changes and closes the dialog. 
• Help – Opens the RxView on-line help system. 
• All On – Click this option to turn all the layers on (no need to 

select layers). 
• All Off – Click this option to turn all the layers off (no need to 

select layers). 
• Default – Click this option to reset the layers to their default 

values (as they were when the file was initially opened). 
• On – Click this option to turn the selected layer on. 
• Toggle – Click this option to toggle the selected layer to the other 

setting (on or off). 
• Off – Click this option to turn the selected layer off. 
Note  When printing a file, only the displayed layers will be printed. 
The layer columns can be rearranged, resized and sorted. 
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7.7 Setting the Background Color 
When the file window is larger than the file image, the area outside the 
image but within the window frame will be given the selected 
background color. RxView provides a choice of three standard colors; 
white, black and gray, and allows you to create your own color as a 
fourth choice. 
Change the background color using the following methods: 

• Click the Toggle Background Color button  on the View toolbar 
– each click toggles the color to the next of the four choices. 

• Go to the View menu and click the Toggle Background Color item 
– each click toggles the color to the next of the four choices. 

• Go to the active file right-click menu and click the Toggle 
Background Color item – each click toggles the color to the next of 
the four choices. 

• Click the down-arrow beside the button and select the desired 
color from the list. 

Note  Only the active file’s background color will be changed. 
Different files can therefore have different background colors. 

7.7.1 Choosing a Non-standard Background Color 
Choose a non-standard background color as follows: 
1. Select the Tools > Options menu item or click Options in the 

active file right-click menu. 
2. On the General tab click the Custom color picker option. 
3. Pick a standard color from the presented color chart. 
4. Click Apply or OK to implement the change.  

7.7.2 Create a Custom Color 
1. Select the Tools > Options menu item or click Options in the 

active file right-click menu. 
2. On the General tab click the Custom color picker option and click 

Other to open a standard Windows color selection dialog. 
3. Once you have the desired color in the Color / Solid box, click 

Add to Custom Colors, and the color will be added to the Custom 
Colors table. 
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4. Click OK to return to the chart of standard colors. 
Your new color is now included in the chart and is automatically 
selected in the Custom Color Picker in the Options dialog. 

5. Click Apply or OK to implement the change. 
Your color is included as the Custom choice in the list of four 
colors in the Toggle Background Color command. 
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Chapter 8 Printing Files 

8.1 Print Dialog 
Click on the Print button  to open the Print dialog, or click the 
File > Print menu item. Before using the Print dialog you can use the 
Page Setup and Print Preview setup to prepare your print. 

8.2 Print 
Print offers a standard Windows print dialog opens.  

 
Figure 30 Windows Print dialog 

This dialog enables you to select the required printer and the required 
pages to be printed. 
• Options – Opens the Options dialog. 
• OK – Sends the file to the selected printer. 
• Cancel – Cancels the print operation and returns to the file. 
Refer to Windows documentation for further details about printing. 

 
 

91



8.3 Page Setup 
Before printing the active file, open the Page Setup dialog to configure 
the page layout. Access the Page Setup dialog as follows: 
• Via the active file right-click menu  
• Via the File > Page Setup menu item. 
• In the Print Preview window, click the Page Setup button. 

 
Figure 31 Page Setup dialog 

• Size – Click the down arrow and select a paper size from the pull-
down list. 

• Source – The selected printer’s driver will automatically present 
the available paper trays in the pull-down list. Select the desired 
paper source. 

• Orientation – Select the required paper orientation. The options 
are Portrait or Landscape. 

• Margins – Type in the required margins. 
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Click Printer to display a standard Windows printer selection dialog. If 
you have several printers or plotters available on your network, select 
the required unit. 
Click OK to close the Page Setup dialog and implement the changes. 
Note  If the active file contains several layers, only those layers that 
are displayed will be printed.  

8.4 Print Preview 
This function opens a preview window and displays the active file as it 
will appear on the paper when you print it out. Proceed as follows: 
1. Select the file you wish to preview. 
2. Start the Print Preview function using one of the methods listed 

below. 
The RxView window changes to the RxView Print Preview 
window, and the active file is displayed. 
Note  If the active file is a multipage file, the preview window will 
automatically present the currently open page. If the 1 Page / 2 
Page function is set to 2 Pages, the currently open page and the 
following page will be presented. 

3. When you have finished previewing the file, click the Close 
button to return to the normal RxView screen layout. 

This function is activated using the following methods: 
• Click the Print Preview button on the standard toolbar. 
• Select the File > Print Preview menu option. 
• Select Print Preview from the active file’s right-click menu. 
Return to the normal RxView screen layout by clicking the Close 
button. 
The Print Preview toolbar contains the following buttons: 

 Print – Sends the file to the selected printer. 
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 First, Next, Previous and Last page – If the active file is a 
multipage file (e.g. a document), use these buttons to move through 
the pages to ensure all will print out as expected. The buttons will be 
inactive if the file comprises a single page or if there are no more 
pages in the relevant direction. 

 1 Page / 2 Page – Toggle this button to view a single page or two 
pages. 

 Zoom In / Zoom Out – These buttons enable you to zoom in and out 
to the preview image for closer inspection. The function has three 
levels of zoom. Note that you can put the cursor onto the preview 
image and click left mouse to toggle through the three zoom levels. 
Options – Opens the Options dialog that holds more print setup and 
watermarking options. Refer to later paragraphs in this chapter for 
details. 
Page Setup – Closes the Print Preview function, returns to the 
RxView display and opens the Page Setup dialog. Go back to 
paragraph 8.1 for further details about this dialog. 
Close – Closes Print Preview and returns to the RxView window. 
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8.5 Print Options 
The Options > Print tab enables you to select the area of the image 
you want to print, position the printed part on the page, and add a 
watermark if required. Click the Print button or the Print Preview 
button and then click the Options button on the Print dialog. 

 
Figure 32 Print > Options dialog 

Print portion 
• Entire page/image – Select this option if you wish to print out the 

entire page/image irrespective of what is currently displayed in the 
RxView file workspace. 

• Displayed portion – Select this option if you wish to print out only 
that part of the page/image that is currently displayed in the 
RxView file workspace. 
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Print control 
• Maintain aspect ratio – Check this box if you wish to maintain 

the aspect ration of the image in the printout. 
• Poster – Check this option, then input the number of pages 

horizontally and vertically you wish the poster to be printed over. 
• Monochrome – Check this option if you want the image to be 

printed in monochrome. 
• Rotation – Select the appropriate rotation angle from this drop 

down list if you want to rotate the printed image relative to the 
selected paper orientation. 

Print scale 
• Standard – Select this option then select a scale from the pull-

down list if you wish to use a standard scaling factor. 
• Scaled from – Select this option then add the desired scaling 

factors to the fields if you wish to use a non-standard scaling 
factor. 

Print offset 
• Standard – Select this option then select an offset from the pull-

down list if you wish to position the image in a standard location on 
the paper. 

• Custom – Select this option then add the desired offsets to the X 
and Y fields if you wish to position the image in a non-standard 
location on the paper. The red square indicates the position of the 
image on the paper. 

Click Apply to implement changes and keep the print tab open, click 
OK to implement changes and close the tab, click Cancel to close the 
tab without implementing any changes, and click Help to access the 
on-line help system. 
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8.6 Print Watermark  
You can add a watermark to the printout, for example to simplify 
identification of the paper or add a date stamp. Go to the RxView Print 
> Options button. Select the Watermark tab to display the dialog 
below. 

 
Figure 33 Print > Watermark dialog 

 
• Enable watermarking – Check this box to enable the 

watermarking function. All other options on the dialog will be 
inactive until this box is checked. 

• Watermark as – Select Top layer to print the image first then print 
the watermark on top of the image (so you can be sure of seeing 
all the watermark). Select Bottom layer to print the watermark first 
then print the image on top of the watermark (so you can be sure 
of seeing all the image). 
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• File Path – Check this option to add the file path to the 
watermark. 

• File Name – Check this option to add the file name to the 
watermark. 

• Current date / time – Check these options to add the current 
date and time to the watermark. The date and time will be that 
which is valid when you click the Apply button on the watermark 
dialog. 

• Custom text – Check this option to allow custom text in the 
watermark. Once you have checked this box, you can then type 
the desired text into the field. Any number of characters can be 
included in this field. Note however that if the text is wider than the 
image, the text will be truncated at the edge of the image. 

You can add the file path, file name and date/time to the custom 
text by using the codes as follows (note that the letters are case-
sensitive): 
− Type %p to include the file path. 
− Type %f to include the file name. 
− Type %d to include the current date. 
− Type %t to include the current time. 

Note  You can fit more text into the image by reducing the font size or 
by positioning the text parallel to the long edge of the image. 
• Alignment – Select how you want the watermark text to be 

positioned on the page. 
• Multiple lines – Check this box to place the file path and name, 

the date, and any custom text, on separate lines in the watermark. 
Note  Any custom text will always be restricted to one line of text. 

• Vertical position – Select where you want the watermark text to 
be positioned on the page. 

• Orientation – Select the angle at which you want the watermark 
text to be positioned on the page. 

• Font options – Click this button to open a standard Windows font 
selection dialog. Click Close in this dialog to return to the 
Watermark tab. 

 
 

98



8.7 Print Header and Footer  
You can add headers and footers to the printout, for example to 
simplify identification of the paper or add a date stamp. The text will 
be written above or below your image and not across the image as in 
Watermark. Go to the RxView Print > Options button. Select the 
Header and Footer tab to display the dialog below. 

 
Figure 34 Print > Header and Footer dialog 

• Enable header – Check this box to enable the header function. 
Options on the dialog will be inactive until this box is checked. 

• Enable footer – Check this box to enable the function. Options on 
the dialog will be inactive until this box is checked. 

• Text and codes – Write your header or use codes to create 
dynamic headers and footers as described in the Watermark 
section. 
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8.8 Print Pen Table  
You can add pen table settings to the printout if the file can use pen 
table settings. Go to the RxView Print > Options button. Select the 
Pen Table tab to display the dialog below. 

 
Figure 35 Print > Pen Table dialog 

Read about pen tables in the previous chapter. The dialog reached 
via Print > Options is identical. 
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8.9 Printing 
When you start the printing function a standard Windows Print dialog 
opens. This enables you to select the required printer and set it up, 
and select the required pages to be printed. 
• Options – Opens the Options dialog. See paragraph 8.5 for 

further details. 
• OK – Sends the file to the selected printer. 
• Cancel – Cancels the print operation and returns to the active file. 
Refer to your Windows documentation for further details about the 
Print dialog. 
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Chapter 9 Special Functions 

9.1 Extract Text (RxHighlight) 
Extract Text function enables you to extract all the text from a drawing 
or document that contain readable text. 

 
Figure 36 Text Extraction dialog 

• Save – Save the text to a text file. 
• Clipboard  – Copies the extracted text to the clipboard. 
• Extract – Extracts text if any from the current file. 
• Close – Close the Batch Print dialog. 
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9.2 Batch Print (RxHighlight) 
Batch Print function enables you to print multiple files as a Batch job. 
Selecting this function from the file menu will open the dialog 
displayed below. 

 
Figure 37 Batch Print dialog 

Use the buttons in the dialog to create and start a batch job. 
• Options – Opens the Options dialog. See paragraph 8.5 for 

further details. 
• Print Setup  – Opens the page setup dialog. 
• Add Files – Add files to the batch print list. 
• Add Folder – Add a file mask for a given folder to the batch print 

list. 
• Remove – Remove the selected file from the batch print list. 
• Save List – Save the current batch print list to a file. 
• Load List – Load a previously saved batch list from file. 
• Start – Start the batch process with the current batch list. 
• Close – Close the Batch Print dialog. 
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Right click menu 
You can modify lines in the batch print list using a menu. Bring up the 
menu by right clicking in the batch print list. 

 
Figure 38 Batch Print dialog menu 

• All pages – Print All pages in the selected file. 
• First Page – Print only the first page in the selected file. 
• Copies – Set the number of copies you want printed of the 

selected file. 

9.3 Batch Conversion (RxHighlight) 
Batch Conversion function enables you to convert multiple files as a 
Batch job. Selecting this function from the file menu will open the 
dialog displayed below. 

 
Figure 39 Batch Conversion dialog 

Set up the batch job using the functions described below. 
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• Options – This is used only if the target format is a raster format. 
It is the same dialog as described later in chapter 11.4.1 

• Destination format  – Select from the available formats in this 
list. Raster files cannot be converted to vector formats. 

• Destination folder  – Select the target folder where you want to 
save the result of the conversion. 

• Add Files – Add files to the batch print list. 
• Add Folder – Add a file mask for a given folder to the batch print 

list. 
• Remove – Remove the selected file from the batch print list. 
• Save List – Save the current batch print list to a file. 
• Load List – Load a previously saved batch list from file. 
• Start – Start the batch process with the current batch list. 
• Close – Close the Batch Print dialog. 
 

9.4 Zoom using mouse wheel 
If you have a mouse with a wheel you can zoom in and out of 
drawings by rolling the wheel forward and backwards. 
 

9.5 Zoom slider 
Zoom Slider function enables you to zoom the active file in or out by 
using a slider button. When this function is accessed, the Zoom Slider 
dialog opens. 

 
Figure 40 Zoom Slider dialog 
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When you open the Zoom Slider dialog, the slider button is positioned 
at the current zoom factor. The current zoom factor is shown in the 
Zoom Scale field. To set the zoom factor: 
• Drag the slider button to the desired zoom factor, or If your mouse 

has a wheel, roll the wheel towards and away from yourself to 
move the slider to the right and left respectively. Or, :Type the 
desired zoom factor into the Zoom Scale box and press Enter on 
your keyboard. 

The zoom slider zooms the image from 1/10 to 10x the image’s 
current extent size (compared to the window), in increments of 0.1x. 
Check the Update Dynamically box if you want the image to be 
updated while you are moving the zoom slider. 
Click Done to terminate the dialog. 
The function maintains the image’s aspect ratio. If the image is too 
large to fit in the window after zooming, pan sliders will be displayed. If 
the resulting image is narrower than the width of the window, the 
image will be centered horizontally in the window and the excess area 
will be given the background color. 

9.6 Scale to Window 
Activate this function using the Scale to Window button  to tie the 
image size to the window size. As you adjust the size of the window 
the image will automatically enlarge or reduce to keep the image as 
large as possible within the window while maintaining the image 
aspect ratio (the ratio of width to height). 

9.7 Scrolling and Panning 
RxView allows two methods of scrolling images (moving the image 
within the viewing window such that areas of the image lying outside 
the window can be viewed): 
• The scroll bars. 
• The pan hand. 

9.7.1 The Scroll Bars 
The scroll bars appear below and/or to the right side of the viewing 
window if the image is too wide or too tall to fit in the window. Use the 
scroll bars as follows: 
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• Put the cursor onto the appropriate square slider button, click and 
hold the left mouse button, and drag the slider horizontally or 
vertically along the bar. The image moves past the window. 
Release the left mouse button when the desired part of the image 
is in view. 

• Put the cursor onto one of the arrow buttons located at both ends 
of the scroll bars and click the left mouse button repeatedly. For 
each click of the mouse button the image will step past the window 
in increments of 1/100 of the vertical or horizontal dimension of the 
image. I.e. 100 clicks of the mouse button will move the slider from 
one end of the scroll bar to the other – the distance the image 
moves for each step will depend on the ratio of the image size 
compared with the window size. 

• Put the cursor onto one of the arrow buttons located at both ends 
of the scroll bars and click and hold the left mouse button. The 
image will step automatically past the window in increments of 
1/100 of the vertical or horizontal dimension of the image. The 
scroll slider moves from one end of the scroll bar to the other in 
approximately five seconds – the speed of movement of the image 
will depend on the ratio of the image size compared with the 
window size. 

• Put the cursor into the scroll bar to one side of the slider button 
and click the left mouse button. For each click of the mouse button 
the image will step past the window in increments of 1/10 of the 
vertical or horizontal dimension of the image. I.e. 10 clicks of the 
mouse button will move the slider from one end of the scroll bar to 
the other – the distance the image moves for each step will depend 
on the ratio of the image size compared with the window size. 

9.7.2 The Pan Hand 
The Pan Hand button toggles the pan function used to view parts of 
an image that are outside the window by grabbing the image and 
moving it. To use the function Click the Pan Hand button  on the 
View toolbar: 
1. Activate the function using one of the methods listed below. The 

Pan Hand cursor appears. 
2. Place the cursor onto the image. 
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3. Click and hold the left mouse button. The hand cursor closes and 
grips the image. 

4. Drag the image around inside the window until the desired part of 
the image is in view. Once you can view the edge of the image 
you cannot drag the image further in that direction.  
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9.8 Rotating Images 
Within RxView there are three methods of rotating images: 
• The Toggle Angle function (not available with 3D images).  
• The Rotation Slider.  
• The Toggle Rotate State  

9.8.1 The Toggle Angle Function 
Use this function to rotate the active image clockwise through preset 
90° steps. The increments are 0°, 90°, 180° and 270°. 
Note  This function is not available for 3D image files. 
This function is activated and deactivated using the following 
methods: 

• Click the Toggle Angle button  on the View toolbar to step 
through the preset angles. 

• Click the “down arrow” beside the button to show a pull-down 
selection list of the preset angles. 

• Put the cursor in the active window and click the right mouse 
button. Select Toggle Rotation Angle in the pull-down menu to step 
through the preset 90° angles. 

• Select the View > Rotate menu option and chose the desired 
rotation angle from the resulting list. 

9.8.2 The Rotation Slider 
Use this function to rotate the active image clockwise through 1° steps 
using a slider bar. When this function is selected one of two possible 
dialogs is displayed depending on the type of file in the active window. 
This function is activated using the following methods: 
• Select the View > Rotate menu option then chose the Slider 

option from the resulting pull-down menu. 
One of the following dialogs opens depending on the file type: 

9.8.2.1 Rotation Slider Dialog 
Note  Two dialogs are available; one for 3D files and one for all 
others. Refer to chapter 3D Files for details about the 3D dialog. 
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When you open the Rotation Slider dialog, the slider will be positioned 
at the current rotation angle. The current rotation angle is shown in 
the Rotation Angle field. 

 
Figure 41 Rotation Slider dialog for all types of files except 3D 

Check the Update Dynamically box if you want the image to be 
updated while you are moving the rotation slider. Drag the slider 
button to the desired rotation angle. Or, type the desired rotation angle 
into the Rotation Angle field. The rotation can be set to any angle 
between 0° and 359°, in steps of 1°. Click Done or press ESC to close 
the dialog. 

9.9 Creating a Mirror Image of a File 
Using the Flip function you can create a mirror image of the active file. 
The file can be mirrored about its vertical and horizontal axes. 
• Right-click on the active file and select Flip > X or Y. 
• Go to the View > Flip menu item and select X or Y. 
The current zoom magnification is maintained. 
 

9.10 Editing Files 
You can edit the active file if the file extension is associated with a 
suitable editing application. 
Select the Edit > Edit Document menu item or click the Edit Document 
button  to start the associated application and open the active file. 

9.10.1 Setting the Edit Application 
Set the edit application for the active file as follows: 
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Open the Filter Settings dialog either by clicking the Filter Settings 
button or by going to the Tools > Filter settings menu item. In the Edit 
Application field, type in the path and .EXE file name of the application 
you wish to use to edit the currently selected file, for example 
RxSpotlight. 
Or: 
Click the browse button beside the field and browse to the application. 
Once the required application is displayed in the Edit Application field, 
click Close. All files with the same file extension as the currently active 
file will hereafter be associated with the selected editing application. 

9.10.2 Editing the File 
Refer to the edit application’s documentation for information about 
editing the file. 

9.11 Magnifying 
9.11.1 The Magnifying Glass 
Click the Magnifying Glass button  to magnify a part of the active 
file and display the enlarged part in an area in front of the file. 
Click the Magnifying Glass button on the View toolbar or select the 
View > Magnifying Glass menu item. Select the shape of the enlarged 
area in the Advanced tab of the Tools > Options dialog.  
Set the magnifying scaling factor in the Tools > Options > General tab 
dialog.  

9.11.2 The Magnifying Window 
Click the Magnifying Window button  to magnify a part of the active 
file and display the enlarged area in a new window. 
Click the Magnifying Window button on the View toolbar. Select the 
View > Magnifying Window menu option. 
Set the magnifying scaling factor in the Tools > Options > General tab 
dialog. 

9.12 Bird’s Eye View 
The Bird’s Eye View function provides an overview of the file, and 
allows you to pan around and select areas to zoom. 
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Click the Bird’s Eye View button  on the View toolbar, or select the 
View > Bird’s Eye menu item. 
Overview of an image 
Activate the function and a total view of the file contents appears in 
the Bird's Eye View window. Change the size of the Bird’s Eye 
window by dragging its borders. 
Zooming 
Place the cursor inside the Bird's Eye View window and press the 
right mouse button. Drag the mouse diagonally to create a frame that 
marks the area you want to zoom into. Release the right mouse button 
and the selected area zooms to fit the file’s view window. 
Panning 
The red indicator frame inside the Bird's Eye View window is 
superimposed over the part of the file currently visible in the file 
workspace. Place the cursor inside the red frame, click and hold the 
left mouse button, and drag the cursor until the frame encloses the 
information you wish to see. As you do so, the view in the work area 
changes to match the area enclosed in the frame. 

9.13 Copying Part of an Image to the Clipboard 
You can select part of an image and copy it to the Windows clipboard. 
From the clipboard you can then paste the image part into another 
application. 
Select the Edit > Copy to Clipboard menu item. A submenu of the 
available formats is displayed. The cursor changes to the Copy to 
Clipboard format. Put the point of the cursor on one corner of the area 
to be copied, click and hold the left mouse button, and drag the mouse 
to create a rectangle around the area to be copied. Release the left 
mouse button to copy the defined area to the Windows clipboard. 
The marked area is placed on the Windows clipboard in the selected 
format. You can now move to another application and select Paste to 
paste the copied area into that application. 
Metafile format is a vector format. 
Bitmap format is raster format. 
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9.14 Multipage and office format functions 
9.14.1 One Page View 
The One Page View button  displays the current page of the 
multipage file in the file window. All the Standard and View toolbar 
functions operate as normal. 

9.14.2 Thumbnail View 
Click the Thumbnail View button  to display all the pages in the file 
(as many as will fit in the window) as thumbnail images. Horizontal 
and vertical pan sliders are displayed as required. The rows and 
columns of images are rearranged to fit as you resize the window. 
The page numbers are displayed below each page. 
Place the cursor in the window but not on a thumbnail then click the 
right mouse button to get a reduced menu, or place the cursor on a 
thumbnail and click the right mouse button to select that page and get 
a full menu. 

9.14.3 Page and Thumbnails View 
Click this button  to split the file window and display both the 
thumbnails and the current page. Use the vertical pan slider to move 
through the thumbnails, and click on the required page. 
The Thumbnails right-click menu functions in the thumbnails column 
as described in the previous paragraph, while the standard Active File 
right-click menu functions in the file display area (see paragraph 
9.20.6 on page 120 for details). 

9.14.4 Paging Through a Multipage File 
Use the Page Up button  and the Page Down button  to move 
through the multipage file. You move one page for each click of the 
button. The button is deactivated when there are no more pages in 
that direction. 
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The Page List box  indicates which page of the multipage file 
is currently displayed. 
• Type the required page number into the box and press Enter. 
Or: 
• Click the arrow button beside the box to display a pull-down list of 

the available pages, then click on a page in the list to display that 
page and close the list. 

Note  Many of the menu options are file-type-dependant, i.e. the 
menu options available at any particular time will depend on the type 
of file that is active at that time. This chapter lists and describes all the 
possible menu options that may be available in RxView. 

9.15 View > Full Screen 
Select this menu item to toggle the current file to display full-screen. 
While the file is displayed full screen the Toggle Full Screen button 

 will be displayed in the upper left corner. Click the button to return 
to the “normal” layout. 
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9.16 Tools > Plugin Manager 
Select this menu item to open the Plugin Manager dialog. You can 
then attach plugins (.DLLs) to RxView to add commands (buttons or 
menus), activate and deactivate functions using dialogs etc. Refer to 
paragraph 6.3 on page 61 for further details. 

9.17 Window > Split 
The active file’s window can be split into four areas to enable you to 
view different areas of the same image at different magnifications. 
Once you have split the window into four, you can move the vertical or 
horizontal dividers as required to resize the sub-windows. 
If you move one of the dividers to the edge of the window, the divider 
will disappear, giving two sub-windows. Re-select the Window > Split 
menu item to return to four sub-windows. 
All zoom, pan and viewing functions operate individually on the 
different parts of the split window. 

9.18 Window > Windows 
This menu item opens the Windows dialog. This dialog lists the files 
that are currently open in the viewer, in the order in which they were 
last active, with the currently active file at the top of the list. 
Note  Set the maximum number of files to be listed in the Tools > 
Options dialog. See paragraph 6.1.1 on page 43 for further details. 
Use standard Windows techniques to select files on the list. The 
buttons are as follows: 
• Activate – Activates the selected file and closes the dialog. Only 

one file can be active; if more than one file is selected the Activate 
button is grayed out. 

• OK – Click OK to close the Windows dialog once you have 
finished using it. 
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Figure 42 Windows dialog 

• Edit – Starts the specified editing application for the selected file 
and opens the file. Only the active file can be edited. If more than 
one file is selected the Edit button is grayed out. 

• Close Window(s) – Closes the selected files. 
• Tile Horizontally – Tiles the selected files such that they fit 

horizontally across the width of the file workspace. The selected 
files are positioned one above the other in the workspace. The “not 
selected” files are minimized and moved to the bottom edge of the 
workspace. 

• Tile Vertically – Tiles the selected files such that they fit vertically 
in the height of the file workspace. The selected files are 
positioned one beside the other in the workspace. The “not 
selected” files are minimized and moved to the bottom edge of the 
workspace. 

9.19 Tip of the Day 
Click this menu option to display a dialog giving a useful tip 
concerning the operation of RxView. Check the Show Tips on Startup 
box to make the dialog appear when RxView R6 starts, uncheck to 
prevent the dialog showing. 

 
 

116



9.20 Right-click Menus 
9.20.1 Toolbar and File Workspace Menu 
Place the cursor in a clear part of the file workspace (not on an open 
file) or anywhere on a toolbar, the menu bar or the title bar, and click 
the right mouse button to display a pull-down list of the options 
available. These are as follows: 
• Workspace bar – Check this item to display the workspace bar. 
• File Explorer – Check this item to display the file explorer 

window, and the folder explorer window if that item is also checked 
(see note below). 

• Folder Explorer – Check this item to display the folder explorer 
window. 

Note  The File Explorer and Folder Explorer windows are 
interlinked as follows: 
− The folder explorer window can be toggled on and off while 

the file explorer is on. If the folder explorer window is off, the 
folder explorer functions (folder browse etc.) then become 
available through the file explorer window. 

− If you toggle off the file explorer window, both the file 
explorer and folder explorer windows will toggle off. 

− You can toggle the folder explorer off, then toggle the file 
explorer on and off separately. 

− If both the file and folder explorers are off, you can toggle 
both on by checking the Folder Explorer option. 

• Standard – Check this item to display the Standard toolbar. Refer 
to paragraph 5.1 for a detailed description of the tools included in 
this toolbar. 

• View – Check this item to display the View toolbar. Refer to 
paragraph 5.2 for a detailed description of the tools included in this 
toolbar. 

• 3D tools – Check this item to display the 3D toolbar. 
• Office tools – Check this item to display the Office toolbar. 
• CAD tools – Check this item to display the CAD toolbar. 
• Address – Check this item to display the file Address list box. 
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• Customize – Check this item to display the Customize dialog. 

9.20.2 RxHighlight right click menus 
If you are running RxHighlight you have two additional toolbars that 
can be on. 
Markup Tools – Check this item to display the Markup Tools toolbar. 
Markup Settings – Check this item to display the Markup Settings 
toolbar. 
 

9.20.3 Folder Explorer Menu 
Note  The folder explorer can be switched on and off separately, but if 
the file explorer is switched off the folder explorer is also switched off. 
If the folder explorer is switched off, the folder information is 
incorporated into the file explorer bar. 

− The folder explorer can be resized as required on the 
screen. To resize the bar, place the cursor on the bar’s 
frame then click and hold the left mouse button and drag the 
frame. Release the mouse button when the bar is the 
desired size. 

− The folder explorer can be positioned as required on the 
screen. To move the bar if it is docked, place the cursor on 
the bar’s grip (the Folder Explorer text or the parallel vertical 
grip lines are easiest, though any part of the bar’s frame can 
be used), then click and hold the left mouse button and drag 
the bar. Release the mouse button when the bar is in the 
desired location. If the folder explorer is undocked (a 
separate window in the workspace) then move the window 
by grabbing the title bar. 

− Note  The grip lines will only be visible if the bar is high 
enough to display more than the bar’s name and path. 

9.20.4 File Explorer Menu 
Place the cursor in a clear part of the file explorer (not on a folder 
name) and click the right mouse button to display a pull-down list of 
the options available. These are as follows: 
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• Large Icons – Check this option if you wish to display the files as 
large icons. The icon used will depend on the type of file. 

• Small Icons – Check this option if you wish to display the files as 
small icons. The icon used will depend on the type of file. 

• List – Select this option if you wish to display the files in a list. 
• Details – Check this option if you wish to display the file details. 

When Details is selected, several new options become available: 
− Place the cursor in the file explorer button bar and click the 

right mouse button to display a pull-down list of the file 
details available. Check/uncheck the items in the list to 
show/hide the file detail columns. 

− The file detail columns can be moved and sized as required. 
To move a column, place the cursor onto the appropriate 
button, click and hold the left mouse button, then drag the 
button to the required place in the button bar and release it. 
You will notice that as you drag the cursor, the nearest 
“space” between the buttons turns blue to indicate where the 
dragged button will be located when you release it. 

− The files listed can be sorted by name, size, file type, 
modification date and attributes, in either direction (up or 
down). Click on the appropriate column button to select the 
desired sort method. Click the same button again to toggle 
the direction (note the arrow indicating the sort direction). 

• Thumbnails – Check this option if you wish to display the files as 
thumbnail images. When this option is selected, the Preview option 
is inactive. 

• Show Preview – Check this option if you wish to display a 
thumbnail preview of the selected file beside the file explorer. If 
several files are selected, only the last selected file will be 
displayed in the preview window. 

The file names can be displayed in the explorer in a variety of ways: 
Note  The Folder explorer can be switched on and off separately, but 
if the File explorer is switched off the Folder explorer is also switched 
off. If the folder explorer is hidden, the folder information is 
incorporated into the file explorer. 
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9.20.5 Workspace Bar Menu 
• The Workspace bar can be docked or used as a Window.  

9.20.6 Active File menu 
Place the cursor in the active file window and click the right mouse 
button to display a pull-down list of the options available. Note that the 
options will vary depending on the type of file that is active. The 
possible options are as follows: 
• Zoom – Put the cursor onto this item to display a submenu of the 

various zoom functions available.  
• Rotate – Put the cursor onto this item to display a submenu of the 

various rotation functions available.  
• Flip - Put the cursor onto this item to display the two choices 

available for flipping the image (creating a mirror image); X flips the 
image around the horizontal axis and Y flips it around the vertical 
axis. 

• Copy to Clipboard – Put the cursor onto this item to display a 
submenu of the various formats available to be used to copy a 
selected part of the image to the Windows Clipboard. Select the 
required format to start the copying process. 

• Measure – Put the cursor onto this item to display a submenu of 
the various items available under the Measure function. Refer to 
paragraph 10.1 on page 122 for further details. 

• Toggle Background Color – Click this option to toggle the 
background color through the four choices. Refer to paragraph 7.3 
on page 84 for further details. 

• Page Setup – Click this option to display the Page Setup dialog. 
Use this dialog to set the page margins, paper size etc. Refer to 
paragraph 8.1 on page 91 for further details. 

• Print Preview – Click this option to display the Print Preview 
dialog. Refer to paragraph 8.4 on page 93 for further details. 

• Print – Click this option to open the Print dialog. 
• Options – Click this option to open the Options dialog. Refer to 

paragraph 6.1 on page 43 for further details. 
• Help – Opens the RxView on-line help system. 
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Note  The Active File right-click menu is deactivated while the Zoom 
In/Out function is active  
 

9.21 Function Keys 
Two keys on your keyboard can be used to toggle functions. These 
are as follows. 

9.21.1 F8 Key 
The F8 key toggles the Ortho mode. This mode restricts calibration 
and measurements to the vertical and horizontal axes. The Ortho 
mode can be toggled on and off at any time during a measurement 
procedure. See paragraph 10.1.2 on page 123 for further details. 

9.21.2 F9 Key 
The F9 key toggles the Snap mode. See paragraph 10.1.1 on page 

122 for further details 
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Chapter 10 Calibration and Measurement 

10.1 Measuring Distances, Angles and Areas 
Toggle the Measure function by clicking the Measure button  on 
the toolbar. 
Note You may have to calibrate your image first. See this chapter. 
The Measurement function enables you to measure the length of a 
line, the angle between two lines, or the area enclosed by multiple 
lines, on the active file. The results - Distance, Angle, Area, 
Accumulated distance - are displayed dynamically in the status bar, 
and will also be displayed in the Measurement Statistics dialog (see 
this chapter). 
The results are displayed using the units of measurement selected in 
the Filter Settings > Measure tab for the particular file type. 
An Orthogonal function is available which restricts the measurements 
to the vertical or horizontal axes. 
A Snap function is available to assist with accuracy when measuring 
to and from particular points on a line. See next paragraph for further 
details. 
The results from the Measurement Statistics dialog can be copied to 
the clipboard then pasted into another application or document. 

10.1.1 Snap 
The Snap function improves accuracy when measuring vector 
drawings. The cursor snaps to defined points (nodes) on the nearest 
line when the cursor moves within a pre-defined range of the node. 
The defined nodes are Nearest, End point, Middle point, and Center, 
and each type of node has a particular cursor shape to indicate the 
node type. 
You can toggle each type of snap node on or off individually in the 
Tools > Options > Advanced tab or through the Active File right-click 
menu under the Options option.  
F9 key on your keyboard toggles the Snap mode as a whole.  
Tools > Options > General > Snap tolerance setting allows you to set 
the pixel snap range. 
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Note  If both the Ortho and Snap functions are activated, when a 
measurement is made that ends near but not on a designated snap 
point, the Ortho mode will automatically be toggled off to enable the 
Snap function to take precedence. 

10.1.2 Orthogonal 
The Orthogonal function restricts calibration and measurements to the 
vertical and horizontal directions in 45-degree steps. 
You can toggle the Ortho function either by checking the option in the 
Tools > Options > Advanced tab or through the Active File right-click 
menu under the Options option.  
F8 key on your keyboard toggles the Ortho mode as a whole.  
Note  If both the Ortho and Snap functions are activated, when a 
measurement is made that ends near but not on a designated snap 
point the Ortho mode will automatically be toggled off to enable the 
Snap function to take precedence. 
The Ortho mode can be toggled on and off at any time during a 
measurement series by pressing the F8 key on your keyboard. 

10.1.3 Measurement Statistics Dialog 
When you have finished measuring an object, angle or area, press the 
ESC key on your keyboard at the last point to stop the function and 
open the Measurement Statistics dialog. This dialog, an example of 
which is shown below, displays the results 
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Figure 43 Measurement Statistics dialog 

• Point – The points you have clicked. 
• Angle – The angles between the lines created. 
• Distance – The distances between the points, in the units of 

measurement defined in the Tools > Filter Setup > Options tab for 
the particular file type. 

• Accumulated distance – The total distance of all the 
measurement operations since the last time the Clear Acc 
Measure button was pressed. 

• Measured area – The area generated by the last measurement 
operation. 

• Accumulated area – The total area generated by all the 
measurement operations since the last time the Clear Acc 
Measure button was pressed. 

• Clear Accumulated – Resets the accumulated totals to zero. 
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• Copy – Copies the measurements and accumulated totals to the 
Windows clipboard so you can paste them into another application 
as a list. The list has tab delimiters between fields so the text can 
be pasted and converted to a table in Word or pasted directly into 
an Excel spreadsheet. 

• OK – Closes the Measurement Statistics dialog. 
 

10.1.4 Measuring the Length of an Object 
1. Zoom in to the image to achieve the appropriate accuracy, click 

the Measure button and move the cursor to one end of the object 
to be measured. 

2. Click the left mouse button, move the cursor to the other end of 
the object and click the left mouse button. An arrow forms behind 
the cursor as you move it, indicating the start point and current 
end-point of the measurement line. Press ESC on the keyboard 
to access the Measurement Statistics dialog. 

The Measurement Statistics dialog is opened and displays the results. 
The results are presented dynamically in the status bar while the 
measurement function is in progress, and will be deleted from the 
status bar when a new function is selected. 
Note  You must toggle the Measure button off to switch off the 
measurement function. 

10.1.5 Measuring the Angle Between Two Lines 
1. Zoom in to the image to achieve the appropriate accuracy, 

activate the Measure function. Move the cursor to one end of the 
angle to be measured and click the left mouse button. 

2. Move the cursor to the apex of the angle and click again, then 
move the cursor to the end of the other line such that the red lines 
define the required angle and click the left mouse button. Press 
ESC on the keyboard to access the Measurement Statistics 
dialog. 
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The Measurement Statistics dialog is opened and displays the results. 
The results are presented dynamically in the status bar while the 
measurement function is in progress. The steps can be repeated as 
often as required, but only the angle between the last two lines is 
displayed in the status bar. All the angles are listed in the 
Measurement Statistics dialog. 
If the Display measurement dialog box option is selected in the Tools 
> Options > Advanced tab, the Measurement Statistics dialog will 
open and display the results. If the option is not checked in the 
Options dialog, the results will be presented dynamically in the status 
bar while the measurement function is in progress, and will be deleted 
from the status bar when the ESC key is pressed. 
Note  You must toggle the Measure button off to switch off the 
measurement function. 

10.1.6 Measuring an Area Enclosed by Multiple Lines 
1. Zoom in to the image to achieve the appropriate accuracy. Click 

the Measure button and move the cursor to a point on the 
boundary of the object to be measured. 

2. Click the left mouse button on the edge of the object to measure 
and move the cursor to the next point. 

3. Continue clicking points around the object until the object is 
completely enclosed. 

4. Press ESC on the keyboard to terminate the measurement. 
The Measurement Statistics dialog is opened and displays the results. 
The results are presented dynamically in the status bar while the 
measurement function is in progress, and will be deleted from the 
status bar when a new function is selected. 
 

10.2 Calibrating an Image 
The Calibration function enables you to measure the length of an 
object on the active file and define a value for that measurement. The 
ratio of the measured distance to the defined distance is remembered, 
and thereafter any distances measured on that file will be multiplied by 
this scaling factor before being presented. The measurements are 
displayed using the units selected in the Filter Settings > Measure tab 
for the particular file type. 
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Note  To calibrate a file, the units of measurement for that file must be 
set to a standard type, i.e. not System. If the Calibrate button is 
inactive, go to the Measure tab in the Filter Settings dialog and 
change the unit type. See chapter 7 for further details about Filter 
Settings. 
Click the Calibrate button on the toolbar, or Calibrate from the Filter 
Settings > Measure tab. 
Snap mode and Orthogonal mode are available to improve accuracy. 
See previous section in this chapter for further details. 
Note  The Calibrate function switches off automatically once you have 
completed a calibration operation. 

1. Click the Calibrate button  and move the cursor to the object 
to be measured. 

2. Activate the Ortho function if required (F8). 
3. Activate the Snap function if required (F9). 
4. Click the left mouse button on one end of the object and drag the 

arrow-headed line to the other end. The length of the connecting 
line is displayed dynamically in the status bar. 

5. Click the left mouse button to stop the line.  
A dialog similar to that shown below is displayed: 

 
Figure 44 Measurement Calibration dialog 

6. Type into the data field the measurement you wish to use for the 
selected distance. 

7. Check the Set as default for all files of this type box if you wish 
the scaling function to apply to all files using the same filter. 
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8. Click OK. 
Further measurements on this file will use the new scale. 
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Chapter 11 Overlay, Compare, Save As 
The Overlay feature allows you to overlay one or more files on a 
background file. Overlay files can be scaled and offset to match a 
background even if they have different scaling.  
The Compare feature allows you to compare two files. Typically, these 
files would be two revisions of a drawing compared so that the 
differences can be clearly seen. The differences are highlighted while 
identical features in the drawings are played down.  
Save As allows you to convert and save a drawing file (vector file or 
raster file) to a raster file format. Typically, CAD drawings can be 
saved to a non-editable format such as TIFF. You can also convert 
and save a selected drawing file (vector file only) to a vector file 
format. Typically, CAD drawings can be saved to a compact non-
editable standard plot format such as HPGL for distribution. 
 

11.1 Overlay 
Overlay allows you to load several files and display them in the same 
view window. Many files can overlay each other simultaneously. To 
overlay files, click the Open button and select the Overlay File item.  
(Overlay is a dynamic dialog. Changes to the overlay can be seen on 
screen as you work.) The result is displayed in a new window marked 
“Compare Window”. The settings applied to the overlay can be 
changed and saved. Load the saved overlay settings file (file 
extension is XWS) and you will re-create the overlay as it was last 
saved. There is no limit to the number of overlay files you can create.  
Note  All files to be overlaid or compared must already be loaded 
before you open the Overlay dialog.  
The Document Overlay and Compare dialog shows a list box. The list 
box shows all the currently loaded files. Only one of these files can be 
selected as the background image the other files will be overlay files.  
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Figure 45 Overlay Selection dialog 

How to overlay files 
1. Load the files that you want to overlay or compare and then click 

the Compare Files button .  

2. In the Document Overlay and Compare dialog select a 
background file in the list box on the left. Click the Select 
document as: > Background radio button. 
The selected file is the background image. Only one file can be 
set as background. Background files have state “B”. 

3. Select an overlay file in the list box on the left. Click the Select 
document as: > Overlay radio button. 
The selected file is the overlay image. You can have multiple 
overlay files. Overlay files have state “O”. 
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The Display Color allows setting of colors. Overlay files will 
normally use the original file colors and the overlay files are 
displayed transparently on top of the background file as a hybrid. 
In Compare mode, the overlay file is displayed on top of the 
background file with an XOR function. This means that any 
differences between the two drawings are best displayed in a 
different color. In Compare mode, different Display colors are 
automatically selected for the active files. 

4. The Display Mode offers Overlay or Compare radio buttons. The 
paragraph above described the difference between Overlay and 
Compare modes. 

5. The Scale entry field allows you to type in an exact scale of the 
overlay image in relation to the background image. 

6. Rotation allows an overlay image to be rotated by selecting the 
desired angle of rotation, 0, 90, 180 and 270 in the Rotation field. 

7. The X-Offset and Y-Offset entry fields allow you to type in the 
exact position in the background file where the overlay file is to 
be displayed. 

8. Snap button makes the overlaid files fit the background. This also 
resets the Overlay Positioning dialog settings and presents a new 
Scale factor. 
(Drag the Overlay and Compare dialog box to one side in order 
to see the result.) 

9. Scale button allow you to draw to lines, one on the background 
and one on the overlay. The overlay will be scaled in accordance 
with the difference in the length of the two lines. 

10. Move button makes the overlaid files fit the background by 
moving the overlay selecting two points. First select the 
background point then the point in the overlay that should be 
moved to the point on the background.  

11. Save stores the settings of the overlay or hybrid to a file with 
extension XWS (Rasterex Workspace) file. 

12. Select OK to confirm the overlay instructions, or Cancel to return 
to the active file window. 

13. To adjust or save the Overlay dialog, click the Compare Files 
button  again.  
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14. You can also visually scale and move overlay files by selecting 
the overlay using the Select Overlay button.  This will highlight 
the overlay with a selection box around the edge of the overlay. 
You can then grab and move the overlay using the mouse. You 
can also scale the overlay by using the handlebars on the 
selection box. 

15. When an overlay is selected you can also directly edit the overlay 
properties in a separate overlay dialog by clicking on the Overlay 
Settings button . 

 
Figure 46 Overlay Selection dialog 

A Rasterex Workspace file contains the, coordinates, scaling and 
rotation of the overlay components. It can have the same name as the 
background file, but with the extension XWS. An XWS workspace file 
can be loaded using the drop-down arrow beside the Open button and 
selecting the item Overlay File.  
Note  The overlay function is useful for pictures and drawings. You 
cannot overlay spreadsheets and documents. 
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11.2 Compare 
Drawing files can be compared to identify changes in a revision 
process. Typically, these files would be two revisions of a drawing and 
the comparison shows the differences between them. The differences 
are highlighted while identical features in the drawings are played 
down. 
(Compare is a dynamic dialog. Changes to the comparison can be 
seen on screen as you work.) The result is displayed in a new window 
marked “Compare Window”. The settings applied to the comparison 
files can be saved and loaded. Load the saved compare settings file 
and you will re-create the compare as it was last saved. There is no 
limit to the number of compare files you can create.  
The process is similar to overlay, but compare files are best viewed in 
different mono-colors. 
Note  All files to be overlaid or compared must already be loaded 
before you open the Overlay dialog.  
The Document Overlay and Compare dialog shows a list box. The list 
box shows all the currently loaded files. Only one of these files can be 
selected as the background image the other files will be overlaid.  
 

How to compare files 
1. Load the files to compare and then click the drop-down arrow 

beside the Open button and select the Overlay item. 
2. In the Overlay and Compare dialog select a background file in 

the list box on the left. Click the Select document as: > 
Background radio button. 
The selected file is the background image. Only one file can be 
set as background. Background files have state “B”. 

3. Click the Display Mode > Compare radio button, and the 
background file is assigned a mono-color. 

4. Select the file to compare in the list box on the left. Click the 
Select document as: > Overlay radio button and the compare file 
is assigned a different mono-color. 
The selected file is marked as an overlay image. Even though 
you can have multiple overlay files, you will not normally use 
more than 2 files for comparison. Overlay files have state “O”. 
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The Display Color allows setting of colors. In Compare mode, the 
overlay file is displayed on top of the background file with an 
XOR function. This means that any differences between the two 
drawings are best displayed in a different color. In Compare 
mode, different Display Colors are automatically selected for the 
active files. Colors are assigned even if the drawings are 
normally displayed as monochrome using the Preferences dialog. 

5. The Display Mode is set to Compare.  
6. The Scale entry field allows you to type in an exact scale of the 

compare image in relation to the background image. This feature 
is not normally used in compare files, as they will be almost 
identical. 

7. Rotation allows a compare image to be rotated by selecting the 
desired angle of rotation, 0, 90, 180 and 270 in the Rotation field. 
This feature is not normally used in compare files, as they will be 
almost identical. 

8. The X-Offset and Y-Offset entry fields allow you to type in the 
exact position in the background file where the compare file is to 
be displayed. This feature is not normally used in compare files, 
as they will be almost identical. 

9. Snap to Background forces the overlaid files to fit to the 
background. This also resets the Overlay Positioning dialog 
settings and presents a new Scale factor. This feature is not 
normally used in compare files, as they will be almost identical. 
(Drag the Overlay and Compare dialog box to one side in order 
to see the result.) 

10. Scale button allow you to draw to lines, one on the background 
and one on the overlay. The overlay will be scaled in accordance 
with the difference in the length of the two lines. 

11. Move button makes the overlaid files fit the background by 
moving the overlay selecting two points. First select the 
background point then the point in the overlay that should be 
moved to the point on the background.  

12. Save stores the settings of the compare or hybrid to a file with 
extension XWS (Rasterex Workspace) file. 

13. Select OK to confirm the overlay instructions, or Cancel to return 
to the active file window. 
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14. To adjust or save the Compare dialog, click the Compare Files 
button  again.  

A Rasterex Workspace file contains the, coordinates, scaling and 
rotation of the compared components. It can have the same name as 
the background file, but with the extension XWS. An XWS workspace 
file can be loaded using the Open button and selecting the compare 
file with the extension XWS.  
Note  The compare function is most useful for drawings. You cannot 
compare spreadsheets and documents. 
 

 

11.3 XWS - Rasterex Workspace files 
Rasterex Workspace files contain the file references and settings for 
creating Overlay or Compare images.  
RxView can use older versions of XWS files created with RxHighlight 
97.  
XWS files created in RxViewX R6 and RxHighlight R6 cannot be read 
by RxHighlight 97 or RxView 97. All users should therefore upgrade to 
the same version of the software. 
You can have many Workspace files comparing different file revisions 
or overlay scenarios.  
Workspace files can be loaded, edited and re-saved with new file 
configurations and settings.  
If the participating files registered in the Rasterex Workspace file are 
not found ion their original locations, then the local folder from which 
the Rasterex Workspace file is opened is searched.  
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11.4 Save As (RxHighlight) 
Save As… menu item allows you to save files in a different supported 
save format. You can save: 
• Raster files to supported raster formats. 
• Vector files to supported raster formats 
• Vector files to supported vector formats 
• Multipage documents to supported raster formats (currently first 

page only) 
• Single page documents to supported raster formats 
 

 
Figure 47 Save dialog 

Save as type offers a dropdown list of available formats. Vector files 
do not have color or compression options. 
File name is the recommended file name with the extension of the 
selected format. 
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11.4.1 Saving to raster 
When saving to a raster format an additional dialog will appear to 
allow the user to select size, resolution and color options for the target 
raster file. 
 The following dialog is displayed: 
 

 
Figure 48 Save to raster file dialog 

Raster type offers a dropdown list of supported raster types or color 
depth for the selected format. As a rule, fewer bits create a smaller 
file.  
Options button, if available, offers the type of compression. 
Select image size group enables you to select the physical size of the 
image after it has been converted. Click on the arrow to open a list 
box of the available options. If you select Custom size, then the Size 
group becomes active and you can select the settings you require. 
Any other selection will apply preset values to the Custom size fields 
and maintain the original aspect ratio. Select a DPI value suitable for 
the type of image being generated. Be aware that this setting will 
dramatically affect the size of the resulting file.  
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Size of file, if saved uncompressed indicates the size of the file that 
will result from converting the current file using the selected settings 
and WITHOUT compression. You can generate extremely large files if 
you create settings that are too large. Always check this field before 
clicking OK. 
Cancel returns to the Select Export Format and File Name dialog. 
OK complete the file save operation. 
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Chapter 12 3D Drawing Files 
RxView allows viewing and markup of 3D files. Most 3D file formats 
require a separate license. 
 

12.1 3D Image File Functions 
12.1.1 Rotating a 3D Image 
12.1.1.1 The Rotate State Button 

Click the Rotate button  on the 3D toolbar. 
The Rotate button enables you to rotate the image about its center 
point such that you can view the image from any direction. Place the 
Rotate cursor on the image. Click and hold down the left mouse 
button. Drag the mouse. 
Note  Hold down the CTRL, ALT or Shift keys on your keyboard as 
you drag the mouse to restrict the image to rotating about the X, Y or 
Z-axes. 
Note  While the Rotate State function is active, the three axes’ 
rotation angles are displayed in the Status bar. 
When the desired view is achieved, release the mouse button. 
The image will stop in the position it is in when you release the mouse 
button. The X, Y and Z-axes in the lower left corner of the file’s 
window indicate the current “direction” of the image view. 
Reset the image to its original view by clicking the Reset 3D Model 
button . 

12.1.1.2 Rotation Slider Dialog for 3D Files 
Select the View >Rotation Slider menu item.  Three sliders are 
provided – one for each axis of rotation. 
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Figure 49 Rotation Slider dialog for 3D files 

Check the Update dynamically box to update the image in the window 
as you move the sliders. Drag the slider buttons to the desired rotation 
angle, you can also move the sliders in steps of 1° using the arrow 
keys.  Click Done or press ESC to close the dialog. 

12.1.2 Spinning a 3D Image 
The Spin function enables you to set the 3D image spinning 
continually about its center point, in any direction and at any speed. 

Click the Spin button  on the 3D toolbar to activate the function. 
Place the Spin cursor on the image. Click and hold the left mouse 
button. Drag the cursor across the image and release the mouse 
button while the mouse is still moving. 
The image will continue to rotate at the speed and in the direction that 
the cursor was moving when you released the mouse button. The X, Y 
and Z-axes in the lower left corner of the file’s window indicate the 
current “direction” of the image view. 
Note  Hold down the CTRL, ALT or Shift keys on your keyboard as 
you drag the image to restrict the image to spinning about the X, Y or 
Z-axes respectively. 
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Click the Reset 3D Model button  to return the image to its start 
position. The image will then recommence spinning in the same 
direction and at the same speed as it was before you clicked the reset 
button. 
To stop the image spinning, deselect the Toggle Spin View button. 
 

12.1.3 Display a 3D Image as Wireframe 
You can display an image as wireframe, i.e. remove the rendering, by 
clicking the Wireframe button  on the 3D toolbar. 

 
Figure 50  A 3D pyramid (left) displayed as wireframe (right) 
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12.1.4 Adding Perspective to a 3D Image 
Click the Perspective button  on the 3D toolbar to change a 3D 
image from a simple isometric view to a view with perspective. 

 
Figure 51  A 3D cube with perspective (left) and as a simple isometric view (right) 

12.1.5 Sectioning a 3D Image 
Using the sectioning functions available on the 3D toolbar, you can 
cut 3D images along planes such that you can see inside the object. 
You can use up to six cutting planes, each of which can be located in 
any position in the image and turned to any angle relative to the 
image. Once the cutting planes are in place you can rotate the image 
to any angle or set it spinning at any speed to achieve the desired 
view. 
You can save a sectioned image and reload it later so that you can 
return to the exact view. 
Note  The effects of sectioning may be more easily identified if the 
Tools > Options > Advanced > Show Image Extents option is toggled 
on. Use the sectioning functions as follows: 
To see the effects of sectioning as you perform the operation, click the 

Enable Cross-Sectioning button  on the 3D toolbar. 
To see the sectioning planes, click the Show Cross-Section Planes 

button . The planes are displayed in pale gray. 
To make a single cut as with a knife: 
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Click the Set Cross-Section button . Place the cursor where you 
want to start the cut, and click and hold the left mouse button. Drag 
the cursor to create the desired cutting plane, and then release the 
mouse button. The part of the image to one side of the cut will 
disappear. To see that part, click the Invert Cross-Section button . 
Use the Rotate function to turn the image to the desired view. 
To set up several cutting planes: 

Click the Set Cross-Section button . 
The Section Clipping dialog appears as shown in Figure 52. 

 
Figure 52 Section Clipping dialog 

Select a plane tab and then use the sliders to position that plane as 
required. Check Invert to see the other part of the image. 
Select other plane tabs as required and set them up. 
Note  The Enable Clipping and Show Plane boxes can be checked 
individually for each plane. 
Use the Rotate functions to turn the image to the desired view. 
To reset the image and remove any section planes, click the Reset 3D 

Model button . Click Reset to remove any changes made to the 
planes. 
Click Load to open a standard File Open dialog enabling you to load a 
previously saved Section Settings file. 
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Click Save to open a standard Save As dialog enabling you to name 
and save the file with the current section settings. 
 

12.1.6 Changing light and material properties 
The surface of rendered models can be set to different degrees of 
reflection and color. The color of the light reflected from the model can 
also be modified using the Material Settings dialog.  
  

 
Figure 53 Material Settings dialog 

The Material settings Dialog contain the following. 
• Enable Materials – This item need to be checked for the different 

settings to take effect. 
• Track Color – This item determine if only the color of the light is 

changed. Turn this off to change the color of the model surface 
itself. 

• Ambient, Diffuse, Specular and Emission – Determine the color 
of the various light sources and reflections. 

• Shininess – Drag slider to change the reflectiveness of the model 
surface. 
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• Dynamic Update – When checked the changes in the dialog will 
immediately be applied in the model without the need to close the 
dialog. 
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Chapter 13 RxHighlight 
If you have installed RxHighlight and have a valid RxHighlight license 
you will have access to the Markup toolbars and menu. 
The markup toolbar has several extensive dialogs that are described 
in detail in the next chapter.  
Markups are drawn with the color and line thickness defined in the 
Line Width and Color settings in the Markup Preferences dialog. 
Text characters and numbers are written using Windows fonts and are 
not affected by the Line Width settings. 

13.1 Markup Tools Toolbar 
This toolbar have some tools have several style options that appear at 
the end of the markup toolbar. Select the appropriate style from those 
offered.   

13.1.1 Enable / Disable  

 Toggles markups display. When markups are disabled, the remaining 
buttons in the markup toolbar are grayed out, except the Markup 
Preferences button. 

 

13.1.2 Save  

 Click this button to save your markups to file. The markups will be 
saved to a file with the same name as the markup file and with the 
extension as specified in the Markup Preferences dialog. The file will 
be saved in the directory specified in the Markup Preferences > File 
dialog. Default location for markups is the viewed file folder. 
 

13.1.3 Markup Preferences  

 Click this button to open the Markup Preferences dialog. This dialog 
box has two tabs; General and File. See chapter Markup Dialogs. 
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13.1.4 User  Control  

 Click this button to open the Markup User Control dialog. 

  See chapter Markup Dialogs. 

13.1.5 Layer Control 

 Click this button to open the Markup Layer Control dialog. 

 See chapter Markup Dialogs. 

13.1.6 Undo  

 Undo the last markup made or edited. The button has only one undo 
level and is grayed out if there is no operation to undo. 

 

13.1.7 Push  

 Select this function to inspect the contents of Note buttons , and to 
connect to files using Link buttons . 

 

13.1.8 Edit  

 Click on this button to activate the Markup Edit function. This allows 
you to select a markup. Markup functions Edit, Move, Size, Rotate, 
Delete, Zoom, Cut and Copy are described in chapter Markup dialogs. 
The commands available for markups vary according to their 
properties. The cursor changes according to available functionality.  

Select the  icon and click a markup, the user or commentator 
name and markup layer show in the status bar. 
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13.1.9 Rubber  

 Click this button to draw markups that hide image information and 
other markups. These markups are invisible but can be selected, 
moved and deleted like visible markups. 
Use this tool to draw free hand, as though with a pen, on the active 
image. Move the curser to the desired start point, click and hold the 
left mouse button, and move the cursor to draw. 
Set the thickness of the rubber using the Rubber Width setting in the 
Markup Preferences dialog. “Rubber” markup color always follows the 
background color of the file. 
 

13.1.10 Link  

 Click on this button to activate the Create Link function. The Link 
function is used to create links from the active image to other 
documents. 
A link icon is placed onto the active file so that the linked files can be 
opened. Select the Push button  to activate the link.  
Link information is stored in a Markup file. If the file registered in the 
link is not found in its original location, then the local folder from which 
the file and Markup is opened is searched.  
The Link function enables you to link other files to the active file. The 
function places a link icon onto the active file so that linked files can 
be opened. 
Making a Link. Activate the Link function by clicking the Link button in 
the RxHighlight toolbar. Place the cursor on the image where the Link 
icon is to appear. Click the left mouse button and the File Open dialog 
appears. Select the file to connect to the link button. A Link button 
appears at the selected spot in the view window.  
Opening a Link. To view an existing link, select the Push icon on the 
RxHighlight toolbar, and using the hand cursor click the Link icon on 
the image to load the file connected to the Link. 
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13.1.11 Text  

 Click on this button to activate the Markup Text dialog. This is used to 
write text directly onto the active file, and is normally used for shorter 
markups. For longer text markups you are recommended to check the 
Hide the text in Note envelope option in the Markup Text dialog. A full 
description of the Markup Text dialog and functions is in chapter 
Markup Dialogs.  
Set the color in the Markup Preferences dialog. 
Set the text font size in the Font dialog displayed when you click on 
the drawing. When working with larger drawings you may need to 
experiment to find the appropriate settings.  
Set the color and thickness of the markup frame and arrow using the 
Line Width and Color settings in the Markup Preferences dialog. 
Note  If you cannot see the text you have written, or it is extremely 
small, this may be because the Line width and text size option is set to 
Absolute document units, i.e. relative to the size of the original 
drawing. For example, text written in a 10 pt. font on an A0 drawing 
will be virtually invisible. Click the Markup Preferences button  and 
set the Line width and text size to Current display units, then rewrite 
the markup. If you wish to delete the original markup, zoom in on the 
area till you can see the markup, then select and delete it in the 
normal fashion. 
Note  When the Line width and text size option is set to Current 
display units, the resulting markup text size will depend on the amount 
of zoom applied to the document when the text is written.  
To write Text, move the cursor to the desired start point, click the left 
mouse button where the text is to appear and the Markup Text dialog 
appears.  
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Figure 54 Markup Text dialog 

 
Write text markups into the dialog. The Text function is normally used 
for short comments. For larger comments, check the Note option. 
Long markup texts can be stored in "envelopes" so they do not cover 
the work area. To inspect the contents of a note, select the  button 
and click the note. Editing text and notes is described in chapter 
Markup Dialogs. 

To change the font, click the Browse button. The Font dialog appears 
enabling you to select the required font, text style and size. 
Check the Arrow and Frame options if required.  
Select the Frame type if used. 
Click OK to show the markup in the work area. 
Editing existing markups is described in chapter Markup dialogs.  
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13.1.12 Pen 

 Select this option to draw free-hand lines, as though using a pen, on 
the active image. Set the color and thickness of the pen using the Line 
Width and Color settings in the Markup Preferences dialog.  
To draw with the Pen, move the curser to the desired start point, 
click and hold the left mouse button, and move the cursor to draw the 
line. Release the mouse button to terminate.  
 

13.1.13 Lines 

 Lines are drawn using this button.  
Set the color and thickness of lines and arrows using the Line Width 
and Color settings in the Markup Preferences dialog. 
Toggle marker mode using the Marker button.  

Click the lines button  and select the line style from the list offered 
at the end of the markup toolbar.  Select from: 
Open - Connecting lines. 
Closed - Closed lines whose enclosed area is transparent (unfilled). 
Filled - Closed lines whose enclosed area is opaque with the markup 
color (filled). 
Edged - Closed lines whose enclosed area is opaque and assumes 
the background color  (filled). 
 
To draw Lines.  Move the curser to the desired start point and click 
the left mouse button. Move the cursor to the desired end-point for the 
line then click the left mouse button again. If you now move the cursor 
further, another line will be drawn using the previous end-point as its 
origin. To stop drawing, click the right mouse button.  
Orthogonal Mode Hold down the SHIFT key when drawing lines and 
the lines are snapped and drawn 45 or 90 degrees relative to the 
screen.   
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13.1.14 Curves 

 Select this button to draw curved lines on the image. Curves have the 
same styles as lines. A curve requires 3 points.  

Click the curves button  and select the curve style from the list of 
buttons.  Select from: 
Open - Connecting curves. 
Closed - Closed curves whose enclosed area is transparent (unfilled). 
Filled - Closed curves whose enclosed area is opaque with the 
markup color (filled). 
Edged - Closed curves whose enclosed area is opaque and assumes 
the background color  (filled). 

 
To draw Curves.  Move the curser to the desired start point and click 
the left mouse button. Move the cursor to the next point and click. 
Continue to the end-point for the curve then click the left mouse button 
again.  Curves can be connected and each curve can be manipulated 
around its 3 points. To stop drawing, click the right mouse button. 
 

13.1.15 Rectangles / Rounded Rectangles 

  Select one of these buttons to draw a rectangular or rounded 
rectangular area. Note that rectangles can be restricted to squares. 
Click the appropriate button and select the style from the list of 
buttons.  Select from: 
Outlined - Rectangle whose enclosed area is transparent (unfilled). 
Filled - Rectangle whose enclosed area is opaque with the markup 
color (filled). 
Edged - Rectangle whose enclosed area is opaque and assumes the 
background color  (filled). 
 
To draw Rectangles, move the curser to the desired start point and 
click the left mouse button. Drag the cursor to draw a rectangle. Click 
the left mouse button again to terminate the action.  
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Square Mode Hold down the SHIFT key when drawing rectangles or 
rounded rectangles and a square or rounded square is drawn.   
 

13.1.16 Ovals / Bubbles 

  Select one of these buttons to draw an oval or bubble. Note that ovals 
can be restricted to circles.  
Click the appropriate button and select the style from the list of 
buttons.  Select from: 
Outlined - Oval or bubble whose enclosed area is transparent 
(unfilled). 
Filled -  Oval or bubble whose enclosed area is opaque with the 
markup color (filled). 
Edged -  Oval or bubble whose enclosed area is opaque and 
assumes the background color  (filled). 
 
To draw Ovals or Bubbles, move the curser to the desired start point 
and click the left mouse button. Drag the cursor to draw an oval or 
rectangle. Click the left mouse button again to terminate the action.  
Circle Mode Hold down the SHIFT key when drawing circles or 
bubbles and a circle or symmetrical bubble is drawn.   

 

13.1.17 Arrows  

 Draws an arrow. Click the appropriate button and select the style from 
the list of buttons.  Select from:  
Single – an arrow. 
Single filled - an arrow with a filled arrowhead. 
Double - a double headed arrow. 
Double filled -  a double-headed arrow with filled arrowheads. 
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To draw Arrows, move the curser to the desired start point (head) 
and click the left mouse button. Move the cursor to the desired end-
point for the arrow then click the left mouse button again.  



Orthogonal Mode Hold down the SHIFT key when drawing arrows 
and the arrows are snapped and drawn 45 or 90 degrees relative to 
the screen.   
Snap. Enable Snap to snap and draw Arrows on drawings. 
 

13.1.18 Dimension Lines  

 Draws a dimension line with embedded measurement. Click the 
appropriate button and select the style from the list of buttons.  Select 
from:  
Lines – a dimension line with line delimiters. 
Circles - a dimension line with dumb-bell appearance. 
Arrows outlined -  a dimension line with a double-headed arrow. 
Arrows filled -  a dimension line with a filled double-headed arrow. 
 
To draw Dimension Lines.  Move the curser to the desired start 
point and click the left mouse button. Move the cursor to the desired 
end-point for the arrow then click the left mouse button again.  
Orthogonal Mode Hold down the SHIFT key when drawing 
dimension lines and the lines are snapped and drawn 45 or 90 
degrees relative to the screen.   
Snap. Enable Snap to snap and draw Dimension Lines on drawings. 
 

13.1.19  Measurement Area 

 Draws a measurement area with embedded area measurement and 
enclosed by lines. The area is always enclosed. Click the appropriate 
button and select the style from the list of buttons.  Select from: 
 
Outlined - Measurement whose enclosed area is transparent 
(unfilled). 
Filled -  Measurement whose enclosed area is opaque with the 
markup color (filled). 
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Hatched -  Measurement whose enclosed area is transparent and 
hatched. 
 
To draw Measurement Areas, move the curser to the desired start 
point and click the left mouse button. Move the cursor to the next point 
and click the left mouse button again. Continue until you join up the 
lines at the start-point. To stop measuring, click the right mouse 
button.  
Orthogonal Mode Hold down the SHIFT key when building the 
measurement area and the lines are snapped and drawn 45 or 90 
degrees relative to the screen.   
Snap. Enable Snap to snap and make area measurements on 
drawings. 
 

13.2 Markup Settings Toolbar 
This toolbar contain settings that apply to selected comments. 
Changes to Color and layers will require necessary user rights.  

13.2.1 Set markup color 

 Click on this button to select the markup color. To select markup color 
you need to have necessary user rights to choose comment color. 
With this button the user can set the color for the currently selected 
comment. 

 

13.2.2 Marker  

 Click this button to toggle the drawing mode between Normal and 
Marker. In Normal mode you draw with opaque colors on the screen, 
while in Marker mode you draw with transparent colors. This gives the 
impression of drawing with a marker pen. Marker mode is effective 
when used on black and white documents such as text documents 
and mono raster images, but less useful on multi-colored images. 
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13.2.3 Markup Line width  

 Select the width of the line used when drawing comments. Line widths 
can be drawn in absolute or current display units. See Markup 
preferences on drawing units.  

 
13.2.4 Comment Layer 

 Select the comment layer that you want your 
comments to be saved on. This will require necessary user rights. 

 

13.2.5 Move to front  

 When two or more comments are overlapping you can move 
comments that are placed behind other comments to the front by 
clicking on this button. 

13.2.6 Push to back 

 When two or more comments are overlapping you can move 
comments that are on top of other comments to the back by clicking 
on this button. 

13.2.7 Edit selected comment 

 If you have selected a comment for editing you can click on this button 
to bring up the markup edit dialog for the selected comment. 

13.2.8 Delete selected comment 

 You can click on this button to delete the selected a comment. 
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Chapter 14 Markup Dialogs and Editing 
If you have the RxHighlight markup plugin loaded and enabled, you 
will be able to make markups on any file that you can open in RxView. 
 

14.1 Markup Preferences Dialog 
Click the Markup Preferences button  on the Markup toolbar. This 
dialog holds two tabs; the General tab and the File tab. 

14.1.1 General Tab 
Use this dialog to control general markup features and options. 

 
Figure 55 Markup Preferences General Tab 
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Layer 
The name of the selected markup layer. All markups are written in this 
layer. If the layer is changed, the new markups are written in the new 
current layer. Layer information is shown in the status bar when a 
markup is selected. 
Color 
The markup color used by the current markup layer. All markups on 
the layer are written in this color. If the color is changed, the color of 
previous markups on this layer is unchanged but new markups are 
written in the new current color. 
Line Width 
Line thickness for the markups in this markup layer. 
Rubber Width: 
Rubber thickness for the rubber markups. 
Text Font 
The font to be used in text markups. Click the Font button to open a 
font selection dialog. New text markups are written in the new font and 
size. 
Measurement Font 
The font to be used for measurement markups. Click the Font button 
to open a font selection dialog. New measurement markups are 
written in the new font and size. 
Apply all above changes to all current markups  
New markups will always be created using the currently selected color 
and layer. However, if existing markups were created in different 
colors or layers, you can change all markups to the current color, 
layer and user by checking this item and pressing the Apply button. 
The changes will only be made to the active file. 
Note This is a powerful command without an undo function. If you 
need to restore the original markup, then close the file and do NOT 
save the markup changes that are offered on exiting.  
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Line width and text size are in 
Absolute document units - The line width selected in the Markup 
Toolbar is relative to the active document's size. A thin markup line on 
a large document (for example an A0 format drawing) may not be 
visible on the screen. 
Current display units - The line width selected in Markup Toolbar is 
relative to the display size. Typically, a markup line visible on the 
screen for a large document (for example an A0 format drawing) will 
be thick when the document is printed or plotted. 
 
 

14.1.2 File Tab 
Use this dialog to control the type of markup storage file and the 
location of the markup file. 

 
Figure 56 Markup Preferences File Tab 
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Markup file type 
• Single file (XCM) - Markups are saved in a single file that 

contains the markups from all the users. The default Single file 
extension is .XCM. 

• 000 - 999 files - Markups are saved in multiple files, one file for 
each commentator. The files are saved sequentially in the range 
000 - 999. 

• X00 - XZZ files - Markups are saved in multiple files, one file for 
each commentator. The files are saved sequentially in the range 
X00 - X9Z. 

Single file extension 
When you select Single file (XCM) as the Markup file type, the XCM 
file extension is added as default. However you can save the markup 
file as any type of file by typing in the appropriate file extension. 
Markup folder type 
You can select in which folder you wish the markup file to be saved: 
• Same as viewed file - The markup file is saved in the same 

folder as the image file to which it is attached. 
• Subfolder to viewed file - The markup file is saved in a subfolder 

to the folder in which the image file is located. Type the name of 
the required subfolder into the Folder or Subfolder field. 

• Separate Markup folder - The markup file is saved in an entirely 
separate folder to that in which the image file is located. Type the 
full path and name of the required folder into the Folder or 
Subfolder field. 

Folder or subfolder 
If you have selected to save the markup file in a subfolder to the 
image file folder, or in an entirely separate folder, then browse to the 
folder or type the path and name of the required markup folder into 
this data field as described above. 
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14.2 Markup User and Layer Control Dialog 
 These dialogs control the display of comments by layer or by user. 
 

14.2.1 User Control Dialog 
Click the User Control button  on the Markup toolbar. 
Use this dialog for an overview of users and markups. Turn On and 
Off markups written by different users, and delete users. 

 
Figure 57 Markup User Control dialog. 

The dialog comprises a list box where each line represents a user 
with his or her signature, and On or Off indicating whether the 
respective user's markups are currently turned on or off. This is a 
dynamic control so you can see the changes on screen when you 
toggle or delete users.  
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14.2.1.1 To Turn Users On and Off 
15. Using standard Windows techniques select one or more users in 

the list box. 
16. Click On, Off or Toggle as appropriate to turn the selected user's 

markups on or off. 
17. Click Close to close the dialog. 

14.2.1.2 To Delete Users 
18. Using standard Windows techniques select one or more users in 

the list box. 
19. Click Del to delete the selected users and their markups - this 

operation removes all the selected markups. 
20. Click OK to confirm deletion, or Cancel to restore the deletion. 
 
Warning! Deleting other users’ markups is an irreversible 
command. If you are in doubt then click Cancel. 
 
Note  Your User Profile determines whether you can delete other 
user's markups. In an organization this will be a restricted command. 
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14.2.2 Layer Control Dialog 
Click the Layer Control button  on the Markup toolbar. 
The dialog comprises a list box where each line represents a Markup 
layer, and On or Off indicating whether the markup layer is currently 
turned on or off. This is a dynamic control so you can see the changes 
on screen when you toggle layers.  

 
Figure 58 Markup Layer Control dialog. 

14.2.2.1 To Turn Layers On and Off 
1. Using standard Windows techniques select one or more layers in 

the list box. 
2. Click On, Off or Toggle as appropriate to turn the selected 

markup layers on or off. 
3. Click Close to close the dialog. 
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14.3 Editing Markups 
14.3.1 Rules 
1. Only the owner of the Markup can edit it.  
2. The current user must own the markup in order to edit it. The 

current user is the person logged into RxView. 
3. To change the current user click the Markup Preferences button 

 and write the new user’s name. The user name is case-
sensitive. Close the dialog.  

4. User information is stored in the markup file. If a user signature is 
changed you may be asked to save the markup file before exiting 
the Markup Preferences dialog. 

 

14.3.2 Selecting markups 
1. Click the  Edit button on the Markup toolbar. 
2. Click a markup. The owners name is shown in the status bar. If 

you are not the owner then you cannot edit the markup. If you 
own the markup then it will be selected. A selection is enclosed by 
a black selection frame, with one or more small buttons or 
handles.  

3.  Click outside the selection to de-select.  
.  

14.3.3 Editing markups 
The editing controls depend on the type of markup. 

 Move a markup by placing the cursor inside the markup selection and 
clicking the left mouse button. The cursor changes from an arrow to a 
hand. Press and hold down the left mouse button, and drag the 
markup to the desired position. Click outside the line to de-select. 

 Zoom or size a markup by placing the cursor on the  button. The 
cursor changes to a finger. The markup is scaled by holding down the 
left mouse button and dragging the corner of the markup. Click 
outside the line to de-select.  
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 Rotate a markup by placing the cursor on the  button. The cursor 
changes to a finger. The markup is rotated by holding down the left 
mouse button and dragging the corner of the markup. Click outside 
the line to de-select.  

 Control button on a selected line, arrow or dimension offers Drag and 
Scale buttons on the markup. Place the cursor on the  button. The 
cursor changes to a finger. Click to access the grip buttons.  

 Drag and scale a markup line, arrow or dimension by placing the 
cursor on the  button. Hold down the left mouse button and drag to 
move or change the length of a line. Click outside the line to de-select. 

 Drag and scale a curve by placing the cursor on the  button. Hold 
down the left mouse button and drag to move or change the length of 
a curve. Click outside the curve to de-select. 

 
Right mouse button menu   

Click the right mouse button to show other options. 

 
Figure 59 Markup Right mouse button menu 

Edit allows you to edit the selected markup. 
Delete allows you to delete the selected markup.  
Bring to Front allows you to move a markup to the front. 
Push Back allows you to move a markup to the back. 
 

 
 

165



14.3.4 Markup Edit dialog 
Edit presents the following common dialog for all markups. 

 
Figure 60 Markup Edit dialog 

The options presented in the Markup Edit dialog are described 
throughout this and the previous sections. 
Changes to markups are not permanent unless the Markup file is 
saved. All comments can also be links. 
You can select a file that you want to use as a hyperlink by clicking on 
the browse button next to the Hyperlink field. You can also type in an 
URL in this field directly. 

 

14.4 Editing Links 
Link buttons can be edited and the link directed to a different file 
through the Select Link File dialog. 
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14.5  Editing Notes 
Note buttons can be edited in the same manner text markups.  
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Chapter 15 Configuring RxView 
 
 
The configuration program is used to set up the users rights and other 
user configuration data. It stores this information in a configuration file. 

 The RxView/RxHighlight Configuration program utility is installed 
automatically. Use it to allocate names to the various markup layers in 
RxHighlight, and to set up User Profiles. 

 
Login is controlled through a username and password.  By using the 
configuration program multiple users can access the RxView and 
markups from the same computer irrespective of the Windows 
username. If the user does not login using a user name and 
password, the Windows login username is used to identify the current 
user. 

 

15.1 Network Administrators! 
Study this chapter carefully and use the Configuration program utility 
to control permissions for users in a network. By using the User 
Profile concept within RxHighlight and RxView, organizations can 
control the viewing (and markup) procedures within the company. 
Each user will have his or her personal User Profile set up by the 
administrator, defining privileges and limitations. 

15.1.1 Markup 
RxHighlight allows annotating of file contents by adding graphics and 
text into markup layers. Markups are stored in separate vector files. 
Files can have multiple markup layers created by separate 
commentators. 
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15.1.2 Linking 
RxHighlight allows link-related files. The link function creates buttons 
on top of the viewed file that connect with other files. Clicking a link 
button loads the linked file. Links are an integral part of markup layers 
and do not require any special configuration. 

15.1.3 User Profile Setup 
In a multi-user environment, User Profiles are set up to control 
creation, viewing, editing and deleting of markups, and permissions 
for operations such as, editing applications and printing. This 
administrative tool gives full control of user rights. 
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15.2 RxHighlight/RxView Configuration Options 
Using the Windows Start menu, open the RxHighlight Configuration 
program utility. The default path is: 
Start > Programs > Rasterex > RxView RxHighlight > RxHighlight 
Plugin > Configuration 
The following screen appears: 

 
Figure 61 Configuration dialog 

15.2.1 Network Administrators! 
Restrict access to the Configuration program to administrators only, 
and do not distribute the configuration program to individual users. By 
using the User Profile concept, you can maintain full control over the 
viewing and commenting procedures within the organization. 

15.2.2 Single Users 
If you are a Single User and not connected to a network, there is no 
need for a User Profile, as you will have all privileges anyway. 
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15.2.3 Network Users 
On starting RxView / RxHighlight for the first time, you may be asked 
to type in your signature. If this signature matches a signature in the 
existing User Profile (see above), the privileges determined by the 
User Profile will automatically be validated. If there is no match 
between signatures, a default profile is loaded. 

15.2.4 Configuring 
1. Set the path to the disk folder in which the file RXCONV.XCF is 

to be saved, by typing the path in the Configuration File Directory 
entry field. The default value is the installation folder. 

2. Set the number of users. (The maximum number of users is 
limited by memory.) 

3. Set the number of layers. (The maximum number of layers per 
user is 2000.) 

4. Click the Markup layer setup button and name and set colors for 
the markup layers required. See paragraph 15.3. 

Note  Set Markup layers before User profiles. 
5. Click the User profile setup and assign a user profile to each 

RxHighlight/RxView user. See paragraph 15.4. 
6. Click Save to save the configuration in the file RXCONV.XCF. 

Click Close to cancel. 
Note Users and layers are controlled in a 2-dimensional array. If 
memory requirements are exceeded, an “Out of memory” warning will 
be presented. Reduce the numbers of layers and users to fit the 
memory. You can change the number of users and layers at any time 
without damaging existing markups. As a rough guide, each user 
requires 16KB, i.e. 1000 users in a 16MB RXCONF.XCF. 
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15.3 Markup Layer Setup 
Click the Markup Layer Setup button. The dialog shown below 
appears: 

 
Figure 62 Setup of Markup Layers dialog 

1. Type the required layer name into the Layer name entry field. 
2. Select a Layer color for the layer. 
3. Edit any name by selecting it from the List of Layer Names. 
4. Click Cancel to cancel session changes. 
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15.4 User Profile Setup 

 
Figure 63 User Profile Setup – Preferences tab 

For RxHighlight and RxView users, the User Profile determines 
whether you will be allowed to: 
• Open files. 
• Close files. 
• Edit file contents. 
• Print files. 
For RxHighlight users, the User Profile also determines what you will 
be allowed to do with markups. Refer to Figure 64. 
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15.4.1 Setting User Preferences 
1. On the Preferences tab, type in a user signature in the User 

signature entry field. 
The typed name will be copied to the List of User Signatures. 
Note  You cannot type a signature in the first entry in the list. The 
first entry is reserved for the default profile. The default profile is 
given to users when the entered signature and password do not 
match in the configuration file. 

2. On the Preferences tab enter the user’s password, if required, in 
the User password entry field. 
If a password is entered, the user must type in this password 
each time RxView or RxHighlight is started and before the profile 
is given to the user. If the user types an incorrect password, the 
default profile described below is applied. 

3. On the Preferences tab enter the default markup layer in the 
Markup layer entry field. 
Users in the same group will normally use the same markup 
layer. 
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15.4.2 Setting User Profiles 

 
Figure 64 User Profile Setup – Profiles tab 

1. On the Profiles tab set the user profile rights by checking the 
required options. 
You can select groups of users using Shift + arrow keys and set 
profiles for them simultaneously. 

2. Repeat the procedure for each user or group of users. 
Note  The Change markup layer option defines whether a user can 
use other layers than the default markup layer. 
Note  The Set default registry settings on WinNT check box is made 
to ease the management of multiple installations on a network. This 
function retains the current settings so they can be used as the default 
for later installations. This enables other users to simply copy the 
default settings made by the administrator. If a user has already 
installed the program and the administrator later checks this box for 
the user, the next time the user starts the program it will adopt the 
default settings set by the administrator. 
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15.4.3 Setting Markup Layers 

 
Figure 65 User Profile Setup – Markup Layers tab 

1. On the Markup layers tab set the markup layers that the user is 
allowed to view. 
You can select groups of users using Shift + arrow keys and set 
the markup layers for them simultaneously. 

2. Repeat the procedure for each user or group of users. 
 

15.4.4 Saving Configuration Data 
When exiting the configuration program you are warned to Save the 

configuration changes. 
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Chapter 16 Supported File Formats 
Check the Rasterex web for latest file format support list. 
 
Rasterex Windows 32-bit filters are named RxFilter_*.DLL. 
The * indicates where a file extension identifier will appear; for 
example RxFilter_DWG.DLL for the AutoCAD DWG file filter. 
When you download a new filter, you will receive an RxFilter_*.DLL 
file. Just copy the new filter DLL into the appropriate subfolder to your 
C:\….\Common Files\Rasterex Shared folder, and RxView will find it 
the next time the program is launched. 
 
Filters may be supplied as self-installing executables. Simple execute 
the file to update your filter. 
 
 

 

 
 

179



 

List of figures 
 

Figure 1 The RxView window..................................................................................21 
Figure 2  Toolbar right-click menu...........................................................................22 
Figure 3  Options dialog General tab ......................................................................43 
Figure 4  Options dialog QuickView tab ..................................................................45 
Figure 5  Options dialog Advanced tab ...................................................................46 
Figure 6  Options dialog File Types tab ..................................................................51 
Figure 7  Customize dialog > Toolbars tab .............................................................52 
Figure 8  Customize dialog > Toolbars tab .............................................................54 
Figure 9  Button Appearance dialog........................................................................56 
Figure 10  Customize dialog > Menu tab ................................................................57 
Figure 11  Customize dialog > Menu tab ................................................................59 
Figure 12  Customize dialog > Options tab.............................................................60 
Figure 13  Plugin Manager dialog ...........................................................................61 
Figure 14  Filter Settings dialog, Information tab ....................................................66 
Figure 15  Filter Settings dialog, Options tab ..........................................................68 
Figure 16 Filter Settings dialog, Measure tab .........................................................70 
Figure 17 Filter Settings dialog, Pen Table tab .......................................................73 
Figure 18 Filter Properties dialog, AutoCAD tab .....................................................74 
Figure 19 Filter Properties dialog, Binary tab..........................................................76 
Figure 20 Filter Properties dialog, CalComp tab .....................................................77 
Figure 21 Filter Properties dialog, MicroStation tab................................................78 
Figure 22 Filter Properties dialog, Gerber tab.........................................................79 
Figure 23 Filter Properties dialog, Text tab .............................................................80 
Figure 24 Filter Properties dialog, VC5 tab .............................................................81 
Figure 25 Pen Table Settings dialog .......................................................................82 
Figure 26 File Properties dialog ..............................................................................84 
Figure 27 File Resources dialog..............................................................................86 
Figure 28 Find text dialog........................................................................................87 
Figure 29 Vector Layer Control dialog ....................................................................88 
Figure 30 Windows Print dialog...............................................................................91 
Figure 31 Page Setup dialog...................................................................................92 
Figure 32 Print > Options dialog..............................................................................95 
Figure 33 Print > Watermark dialog ........................................................................97 
Figure 34 Print > Header and Footer dialog............................................................99 
Figure 35 Print > Pen Table dialog........................................................................100 
Figure 36 Text Extraction dialog............................................................................102 

 
 

180



Figure 37 Batch Print dialog ..................................................................................103 
Figure 38 Batch Print dialog menu........................................................................104 
Figure 39 Batch Conversion dialog .......................................................................104 
Figure 40 Zoom Slider dialog ................................................................................105 
Figure 41 Rotation Slider dialog for all types of files except 3D............................110 
Figure 42 Windows dialog .....................................................................................116 
Figure 43 Measurement Statistics dialog ..............................................................124 
Figure 44 Measurement Calibration dialog ...........................................................127 
Figure 45 Overlay Selection dialog .......................................................................130 
Figure 46 Overlay Selection dialog .......................................................................132 
Figure 47 Save dialog............................................................................................136 
Figure 48 Save to raster file dialog........................................................................137 
Figure 49 Rotation Slider dialog for 3D files..........................................................140 
Figure 50  A 3D pyramid (left) displayed as wireframe (right)...............................141 
Figure 51  A 3D cube with perspective (left) and as a simple isometric view (right)142 
Figure 52 Section Clipping dialog..........................................................................143 
Figure 53 Material Settings dialog.........................................................................144 
Figure 54 Markup Text dialog................................................................................150 
Figure 55 Markup Preferences General Tab.........................................................157 
Figure 56 Markup Preferences File Tab................................................................159 
Figure 57 Markup User Control dialog. .................................................................161 
Figure 58 Markup Layer Control dialog.................................................................163 
Figure 59 Markup Right mouse button menu........................................................165 
Figure 60 Markup Edit dialog ................................................................................166 
Figure 61 Configuration dialog ..............................................................................171 
Figure 62 Setup of Markup Layers dialog .............................................................173 
Figure 63 User Profile Setup – Preferences tab ...................................................174 
Figure 64 User Profile Setup – Profiles tab...........................................................176 
Figure 65 User Profile Setup – Markup Layers tab...............................................177 

 
 
 

 
 

181



Index 
 

Apply new color to all redlines156 
3 

3D 116 

Arrows/Dimension Lines Button 151, 
152 

Associate files of this type with 
RxView 67 Adding Perspective 140 

Converting to Wireframe 139 
Files 16 Auto Detect Plotter Settings 76 

Functions 137 Auto Load Pen Table Settings 72 
AutoCAD Tab 73 Rotate State Button 137 

Rotating Images 137 B Rotation Slider Dialog 137 
Sectioning 140 Background Color 68 
Spinning Images 138 
Toolbar 40 

Create a Custom Color 88 
Non-Standard 88 

3D Image File Functions 137 Setting 88 
Batch Conversion 103 
Batch Print 102 A 
Binary Tab 75 Accumulated Area 123 Bird’s Eye View 110 Accumulated Distance 123 

Activate 114 Bird’s Eye View Button 37 
Block Utilities Toolbar 39 Active File menu 119 Blocks Tab 27 Active file tabs 57, 58 

Add .DGN Extension to Reference 
Files 77 

Buttons 
Arrows/Dimension Lines 151, 152 
Bird’s Eye View 37 Adding a Watermark 96 Calibrate 36 Adding Perspective 140 

Address 116 Close 32 
Delete All Items 40 Address history size 44 Delete Item 40 Address List Box 40 Edit 145 Administration and Permissions 16 Edit Document 33 Advanced Tab 46 

Alignment 97 Enable Cross-Section 41 
File Explorer 33 All Off 87 Filter Settings 33 All On 87 

Angle 123 Information 146 
Invert Cross-Section 41 Aperture Number 78 Layers 39 Aperture Units 79 

 
 

182



Lines 149 
Link 146 

Toggle Angle 36 
Toggle Color 36 

Magnifying Glass 36 Toggle Full Screen 33 
Magnifying Window 37 
Measure 36 

Undo 145 
Wireframe 40 

Measurement Area 152 Zoom 1:1 34 
Next Block 38, 39 Zoom All 34 
No Redlines 144 Zoom Height 35 
One Page View 38 
Open 32 

Zoom In 34 
Zoom In/Out 35 

Open Next 32 Zoom Out 34 
Open Previous 32 
Ovals/Bubbles 151 

Zoom Width 34 

Edged 149, 150, 151, 152, 153 C 
Filled 149, 150, 151, 152 CAD style zoom window 46 Outlined 149, 150, 151, 152 CalComp Tab 76 Page and Thumbnails View 38 Calibrate Button 36 Page Down 37 Calibrate button inactive 125 Page List Box 38 Calibrate Options 48 Page Up 37 Calibrating a File 125 Pan Hand 35 Calibrating and Measuring 121 Pen Table 39 

Perspective 40 Center 48 
Change 82 Previous Block 39 

Print 34 Changing a Button Icon 56 
Clear Accumulated 123 Print Preview 34 

Push 145 Clipboard Extracted text 101 
Clock 24 Rectangles/Rounded 150 
Close Redline Preferences 144 

Button 32 Redline User Control 145 
Window(s) 115 Reset 3D Model 41 

Commands 52 Rubber Pen 146 
Save 144 Comment 

Layer Setup 169, 171 Scale To Window 36 
Comment Layers Setup 175 Set Cross-Section 41 
Commenting 167 Show Cross-Section Planes 41 

Spin 40 Comments 28 
Compatibility Rules 28 Standard Toolbar 32 

Text 147 File Compatibility 28 
in a Single File 28 Thumbnail View 38 

 
 

183



in Multiple Files 28 D 
Policy 28 Database storage 44 Common Folder 45 Decimal Precision 70 Comparing Files 131 

Compression 84 Default 82, 87 
Default Font 74 Configuration 

Options 169 Delete All Items Button 40 
Program 167 Delete Item Button 40 

Delete Users 160 Configuration Data Saving 175 
Configuring 170 Deleting a Menu Item 59 

Details 118 Document Properties Bar 64 Dialog File Explorer 25 Customize 52 File Explorer Bar 64 Dialogs Folder Explorer 64 
RxView 43 Redline User and Layer Control

 155, 159 Toolbars and the Menu Bar 62 Disable this filter 69 Configuring RxHighlight 167 
Conventions 18 Disclaimer iii 

Display clock on status bar 50 Converting to Wireframe 139 
Copy 124 Display List 78 

Display measurement dialog box 48 Copy to Clipboard 119, 124 Displayed portion 94 Copying to the Clipboard 111 
Copyright ii Displaying and Hiding Toolbars 54 

Distance 123 Create Document Properties Bar a Custom Color 88 
Links 146 Configuring 64 
Notes 165 Document Properties Button 33 

Done 124 Creating a Mirror Image of a File109 Dots per inch 84 Creating a New Menu Item 52 Double-click 26 Creating Your Own Toolbars 54 DPI 84 Current date / time 97 
Custom 95 Drag and drop 26 

Color Picker 44 E Text 97 
Customize 117 Edged 149, 150, 151, 152, 153 
Customize Dialog 52 Edit 115 
Customizing 

Commands 52 comments 145 
Edit Application 69 Tabbed MDI 57, 58 

Toolbars 54 Edit Application, Setting the 109 
Edit Button 145 

 
 

184



Edit Document Button 33 File Types Tab 51 
Editing Files 137 File Workspace Right-click Menu 24 
Enable 

Ortho 48 
Fill drawing polygons 47 

Snap 48 
Filled 149, 150, 151, 152 

Watermarking 96 
Filter 

Settings 66 
Enable Cross-Section Button 41 Filter Properties 
End Of Block Character 76 AutoCAD Tab 73 
End point 48 Binary Tab 75 
Entire page/image 94 
Exit 175 

CalComp Tab 76 
Gerber Tab 78 

Extra Sync Character 76 MicroStation Tab 77 
Extract Text 101 Text Tab 79 

VC5 Tab 80 
Filter Settings Button 33 F 
Filter Settings Dialog F8 Key 120 Information Tab 66 F9 Key 120 Measure Tab 70 File 

Calibration 125 Options Tab 68 

Editing 137 Pen Table Tab 72 
Filter Setup 73 Mirror Image 109 

Name 97 Find specified text dialog 86 

Path 83, 96 Flip 119 

Security 17 Folder Explorer 25, 116 

Type 83 Right-click Menu 117 

Units 78 Folder or subfolder 158 

Workspace 24 Font Folder 74 
Font options 97 File Compare 131 Font Resource File pathname 77 File Conversion 16 Full Screen 113 File Explorer 25, 116 

Button 33 Function Keys 120 

Configuration 25 G Menu 117 
Moving Columns 25 General Tab 43 
Opening Files 26 Gerber Tab 78 
Right-click Menu 26 Getting Started 21 
Sorting File Details 25 GIF iii 

File Resources Dialog 85 Goto 79 
File tabs 57, 58 Governing law iii 

 
 

185



Grant of license ii Color 82 
Style 82 
Width 82 H 

Help 82 Line width and text size are in 157 
Lines Button 149 Hide Frozen Layers 74 Link Button 146 Hole Size 79 Linking 16, 29, 168 How to Links overlay files 128, 131 Creating 146 

Opening 146 
I List 118 

Load 82 Ignore File Types 51 
Image 

Depth 84 
ACIS Models 74 

Height 83 
Raster Reference Files 77 

Width 83 
Local Copy 83 

M Incremental Coordinates 78 
Information Button 146 Magnifying Glass 110 Information Tab 66 
Installation 19, 30 Button 36 

Shape 49 Installing Magnifying scaling factor 44 From CD 19 
Introduction 15 Magnifying Window 110 

Button 37 Invert Cross-Section Button 41 Main Window 21, 22 
Maintain aspect ratio 95 

K Making a Link 146 
Margins 91 Keep drawing colors 69 
Markup 16 Keep RxView always on top 49 
Measure 119 
Measure Button 36 L 
Measure Tab 70 

Large Icons 118 Measurement Area Button 152 
Layer Control Dialog 155, 159 Measurement Font 156 
Layer Control Tab 161 Measurement Statistics Dialog 122 
Layers 

Button 39 
Measuring 

An Enclosed Area 125 
Layouts Tab 27 Distances, Angles and Areas 121 
Limitation on liability ii The Angle Between Two Lines124 
Limited warranty ii The Length of an Object 124 
Line 

 
 

186



Menu O 
Creating new item 52 
Deleting 59 Off 87 

On 87 Help > Tip of the Day 115 One Page View 112 Tools > Plugin Manager 114 One Page View Button 38 View > Full Screen 113 Open Window > Split 114 Button 32 Window > Windows 114 Next Button 32 MicroStation Tab 77 Previous Button 32 Middle point 48 Open with embedded viewer 67 Mono drawing display 47 
Monochrome 95 Opening 

and Closing Files 32, 66 Moving Columns 25, 64 
Multipage 116 Links 146 

Options 47 Opening Files 26 
Toolbar 37 Files of Type List Box 41 

Multipage File 
Functions 112 

Options 43, 90, 100, 102, 104, 119 
Tab 68 

Options Dialog One Page View 112 
Advanced Tab 46 Page and Thumbnail View 112 
File Types Tab 51 Paging Through 112 
General Tab 43 Thumbnail View 112 
QuickView Tab 44 Multiple lines 97 

Orientation 91, 97 
Orthogonal 122 N 

Name 79 Outlined 149, 150, 151, 152 

Nearest 48 Ovals/Bubbles Button 151 
Overview of an image 111 Network 

Administrators! 167, 169 P Users 170 
Network Installation 20 
Next 79 

Page and Thumbnails View 112 
Page and Thumbnails View Button38 
Page Down Next Block 38, 39 

Button 37 No Redlines Button 144 
Page List Box 38 No. of mm per unit 71 

Non-standard Background Color 88 
Normal 47 

Page Setup 119 
Page Up 

Notes 
Creating 165 

Button 37 
Paging Through a Multipage File112 

 
 

187



Pan Hand 106 
Button 35 

Page Setup 91 

Panning 111 
Print Preview 92 

password 173 
Priority 68 
Progress Bar 24 

Pen Table 
Button 39 

Properties 67 
PS LT Scale 73 

Pen Table Dialog 81 Push Button 145 
Pen Table Tab 72 
Perspective Q 

Adding 140 
Button 40 QuickView Tab 44 

Plugin Manager 61, 114 
R Plugins 15 

Point 123, 142 
Poster 95 

Raster Options 47 
Recalculate Extents 74 

Preserve black 47 
Prev 79 

Recent file list contains 44 
Rectangles/Rounded Button 150 

Previous Block button 39 
Print 119 

Redline file type 158 

Button 34 
Redline folder type 158 

Options 94 
Redline Preferences Button 144 
Redline Toolbar 144 

Print Dialog 90 Redline User and Layer Control 
Dialog 155, 159 Print Header and Footer 98 

Print Pen Table 99 Redline User Control Button 145 
Print Preview 92, 119 Redlining Functions 155 

1 Page 93 Reference File Folders 77 
2 Page 93 
Button 34 

Reload documents at startup 49 

Close 93 
Remove Hidden Lines 46 
Repositioning 

First Page 92 the Menu Bar 62 
Last Page 92 Toolbars 62 
Next Page 92 
Options 93 

Requirements 19 
Requirements 30 

Page Setup 93 Reset 3D Model Button 41 
Previous Page 92 
Print 92 

Resizing 
Toolbars 62 

Zoom In 93 Resolution 71 
Zoom Out 93 

Printing 90, 100 
Retain page view 47 
Right-click Menu 

and plotting 15 Active File 119 

 
 

188



File Explorer 26, 117 Using the Pan Hand 106 
File Workspace 24 SDI behavior 49 
Folder Explorer 117 Sectioning 
Toolbar and File Workspace 116, 

117 
Several Cutting Planes 141 
Single Cutting Plane 140 

Workspace Bar 27, 119 Sectioning a 3D Image 140 
Right-click Menus 116 
Rotate 119, 145 

Set Cross-Section Button 41 
Set default registry settings 174 

Rotate State Button 137 Setting Background Color 88 
Rotating a 3D Image 137 Setting Comment Layers 175 
Rotating Images 108 
Rotation 68 

Setting the Edit Application 109 
Setting Up the Filters 73 

Rotation Slider 108 Setting Up the Page 91 
3D Files 137 Setting Up the RxView Options 43 
All Files Except 3D 108 Setting user preferences 173 

Rubber Pen 146 Setting user profiles 174 
RxHighlight 

Configuration 167 
Setup 

Comment Layer 169, 171 
User Profile 172 

Shape 78 S 

Save 82 Show 
axes for 3D documents 46 Save Button 144 image extents 47 Save Extracted text 101 Preview 118 Saving Configuration Data 175 

Scale 81 Tooltips 54, 60 
Show Cross-Section Planes Button

 41 Scale to gray 47 
Scale to Window 105 Showing and Hiding Columns 64 Scale To Window Button 36 Showing and Hiding the Toolbars 62 Scaled from 95 
Scaling 47, 84 Single file extension 158 

Single Users 169 Screen Layout Size 79, 83, 91 File Explorer 25 Size X 78 File Workspace 24 Size Y 78 Folder Explorer 25 Small Icons 118 Status Bar 24 Snap 121 Workspace Bar 26 Options 48 Scroll Bars 105 
Scrolling 105 Tolerance 44 

Sorting File Details 25, 65 Using Scroll Bars 105 Source 91 

 
 

189



Spin Button 40 Toggle Full Screen Button 33 
Spinning a 3D Image 138 
Split 114 

Toggle Rotate State Button 40 

Spread Sheet Options 47 
Standard 95, 116 

Toolbar and File Workspace Menu
 116, 117 

Toolbar Icons 144 
Standard Toolbar 32 Toolbars 54 
Status Bar 24 

Clock 24 
Configuring 62 
Create your own 54 
Displaying and Hiding 54 Progress Bar 24 
Redline 144 Rotation Angle Display 137 
Repositioning 62 Unit Type 24 
Resizing 62 X Position 24 

Y Position 24 
Style 79 

Sowing and Hiding 62 

Support 18 
Tools 

Customize 52 
Tools > Options menu 43, 52 Supported File Formats 177 
Tools > Plugin Manager 114 Sync Character 76 
Trademarks iii 
Translation 20, 31 T 
Turn Users On and Off 160, 161 

Tabbed MDI 57, 58 
Temp Folder 83 

Type 70 

Temp Name 83 
Terms ii U 

Text 
Button 147 

Undo Button 145 

Tab 79 
UNISYS LZW iii 
Unit Type 24 

Thumbnail View 112 
Button 38 

Units 82 

Thumbnails 118 
Use AutoCAD Fonts 74 
Use Checksum 76 

Tile 
Horizontally 115 

Use Double Sync Character 76 

Vertically 115 
Use embedded preview if available

 44 
Tip of the Day 115 
Toggle 87 

Use MicroStation Fonts 77 
User Control Dialog 155, 159 

Toggle Angle 
Button 36 

User Control Tab 155, 157, 159 

Function 108 
User Preferences 173 
User Profile Setup 168, 172 
User profiles, set 174 Toggle Background Color 119 
User Signature 156 Toggle Color Button 36 

 
 

190



V 

VC5 Tab 80 
Vector Layer Control 86, 120 

Layers Button 39 
Vertical position 97 
View 116 
View > Full Screen 113 
View Toolbar 34 
Viewing a Multipage File 112 
Viewing functionality 15 
Viewing Functions 101 
Views Tab 27 

W 

Watermark 96 
Watermark as 96 
Welcome 15 
Wheel Mouse 

Zoom Slider 105 
When available use UPI from file 71 
Wildcard 69 
Window > Split 114 
Window > Windows 114 
Window Menu 114 
Window menu contains 44 
Window tabs 57, 58 
Windows 114 
Wireframe Button 40 
Wireframe, Converting to 139 
Word Wrap 80 
Workflow Integration 17 
Workspace 24 

Workspace Bar 26 
Blocks Tab 27 
Layouts Tab 27 
Right-click Menu 27 
Views Tab 27 

Workspace Bar Menu 119 

X 

X Position 24 
X-Offset 84 
Xref Folders 74 

Y 

Y Position 24 
Y-Offset 84 

Z 

Zoom 119 
Zoom 1:1 Button 34 
Zoom all 47, 48 
Zoom All Button 34 
Zoom Height 104 
Zoom Height Button 35 
Zoom In Button 34 
Zoom In/Out Button 35 
Zoom Out Button 34 
Zoom Slider Button 35 
Zoom Using the Mouse 105 
Zoom width 48 
Zoom Width Button 34 
Zooming 104, 111 

 
 

 
 

191


	Introduction
	
	
	
	Welcome to RxHighlight and RxView R6
	RxView R6
	Viewing functionality
	Printing and plotting
	Plugins
	3D Files
	Administration and Permissions

	RxHighlight
	Batch print and conversion
	File Save As
	Markup
	Linking
	Workflow Integration
	File Security

	Conventions
	Support




	Installation
	Requirements
	Installation
	Network License Keys
	Translation
	Documentation

	Getting Started
	Overview
	Main Window
	Controlling the Toolbars
	Standard toolbar
	View toolbar
	3D toolbar
	Office toolbar
	CAD toolbar
	Address toolbar
	Markup Tools Toolbar
	Markup Settings Toolbar

	Status Bar
	Workspace Area
	Workspace Area Right-click Menu

	Folder Explorer
	File Explorer
	Configuring the Information Columns
	Moving Columns
	Sorting File Details
	Opening Files
	File Explorer Right-click Menu

	Workspace Bar
	Views Tab
	Blocks Tab
	Layouts Tab
	Workspace Bar Right-click Menu

	Markups
	Markups in Multiple Files
	Markups in a Single File
	Markup Policy
	Compatibility with Earlier Markup Files

	Document Linking

	Viewing Features and Samples
	Samples folder
	Compare folder
	Overlay folder
	Markup folder

	Toolbar Buttons
	Standard Toolbar
	Open
	Open Previous
	Open Next
	Save As
	Close
	File Explorer
	Workspace Bar
	File Properties
	Find Text
	Toggle Full Screen
	Filter Settings
	Edit Document
	Back Link and Forward Link
	Print
	Print Preview

	View Toolbar
	Zoom All
	Zoom 1:1
	Zoom In
	Zoom Out
	Zoom Width
	Zoom Height
	Zoom Previous
	Zoom Window
	Pan Hand
	Zoom In/Out
	Scale To Window
	Toggle Angle
	Calibrate
	Measure
	Toggle Color
	Magnifying Glass
	Magnifying Window
	Bird’s Eye View
	Compare and Overlay
	Select overlay
	Overlay properties.

	Office Tools Toolbar
	Page Down
	Page Up
	Page List Box
	One Page View
	Thumbnail View
	Page and Thumbnails View
	Zoom List Box
	Zoom 100%
	Gridlines

	CAD Tools Toolbar
	Previous View and Next View
	Previous Layout and Next Layout
	Toggle Block Mode
	Previous Block and Next Block
	List Attributes for Selected Block
	Search Attributes
	Pen Table Settings
	Vector Layers
	Entity information

	Address Toolbar
	3D Toolbar
	Rotate
	Spin
	Wireframe
	Perspective
	Reset 3D Model
	Enable Cross-Section
	Show Cross-Section Plane
	Cross-Section Clipping
	Set Cross-Section
	Invert Cross-Section
	Material and light


	Configuration and Customization
	Setting Up the RxView Options
	General Tab
	QuickView Tab
	Advanced Tab
	File Types Tab

	The Customize Dialog
	Commands
	Creating a New Menu

	Toolbars
	Displaying and Hiding Toolbars
	Creating Your Own Toolbars
	Changing a Button Icon

	Keyboard
	Menu
	Context menus
	Other options
	Deleting a Menu Item

	Options

	Plugin Manager
	Configuring Toolbars and the Menu Bar
	Resizing Toolbars
	Repositioning Toolbars and the Menu Bar
	Showing and Hiding the Toolbars
	Via the File Workspace Right-click Menu
	Via the Customize Menu


	Configuring the Folder Explorer
	Configuring File Explorer
	Showing and Hiding Columns
	Moving Columns
	Sorting File Details


	RxView Dialogs
	Filter Settings
	Information Tab
	Options Tab
	Measure Tab
	Pen Table Tab
	Filter Properties
	The AutoCAD Tab
	The Binary Tab
	The CalComp Tab
	The MicroStation Tab
	The Gerber Tab
	The Text Tab
	The VC5 Tab


	Pen Table Dialog
	File Properties Dialog
	File Resources Dialog
	Find specified text dialog
	Vector Layer Control
	Setting the Background Color
	Choosing a Non-standard Background Color
	Create a Custom Color


	Printing Files
	Print Dialog
	Print
	Page Setup
	Print Preview
	Print Options
	Print Watermark
	Print Header and Footer
	Print Pen Table
	Printing

	Special Functions
	Extract Text (RxHighlight)
	Batch Print (RxHighlight)
	Batch Conversion (RxHighlight)
	Zoom using mouse wheel
	Zoom slider
	Scale to Window
	Scrolling and Panning
	The Scroll Bars
	The Pan Hand

	Rotating Images
	The Toggle Angle Function
	The Rotation Slider
	Rotation Slider Dialog


	Creating a Mirror Image of a File
	Editing Files
	Setting the Edit Application
	Editing the File

	Magnifying
	The Magnifying Glass
	The Magnifying Window

	Bird’s Eye View
	Copying Part of an Image to the Clipboard
	Multipage and office format functions
	One Page View
	Thumbnail View
	Page and Thumbnails View
	Paging Through a Multipage File

	View > Full Screen
	Tools > Plugin Manager
	Window > Split
	Window > Windows
	Tip of the Day
	Right-click Menus
	Toolbar and File Workspace Menu
	RxHighlight right click menus
	Folder Explorer Menu
	File Explorer Menu
	Workspace Bar Menu
	Active File menu

	Function Keys
	F8 Key
	F9 Key


	Calibration and Measurement
	Measuring Distances, Angles and Areas
	Snap
	Orthogonal
	Measurement Statistics Dialog
	Measuring the Length of an Object
	Measuring the Angle Between Two Lines
	Measuring an Area Enclosed by Multiple Lines

	Calibrating an Image

	Overlay, Compare, Save As
	Overlay
	Compare
	XWS - Rasterex Workspace files
	Save As (RxHighlight)
	Saving to raster


	3D Drawing Files
	3D Image File Functions
	Rotating a 3D Image
	The Rotate State Button
	Rotation Slider Dialog for 3D Files

	Spinning a 3D Image
	Display a 3D Image as Wireframe
	Adding Perspective to a 3D Image
	Sectioning a 3D Image
	Changing light and material properties


	RxHighlight
	Markup Tools Toolbar
	Enable / Disable
	Save
	Markup Preferences
	User  Control
	Layer Control
	Undo
	Push
	Edit
	Rubber
	Link
	Text
	Pen
	Lines
	Curves
	Rectangles / Rounded Rectangles
	Ovals / Bubbles
	Arrows
	Dimension Lines
	Measurement Area

	Markup Settings Toolbar
	Set markup color
	Marker
	Markup Line width
	Comment Layer
	Move to front
	Push to back
	Edit selected comment
	Delete selected comment


	Markup Dialogs and Editing
	Markup Preferences Dialog
	General Tab
	File Tab

	Markup User and Layer Control Dialog
	User Control Dialog
	To Turn Users On and Off
	To Delete Users

	Layer Control Dialog
	To Turn Layers On and Off


	Editing Markups
	Rules
	Selecting markups
	Editing markups
	Markup Edit dialog

	Editing Links
	Editing Notes

	Configuring RxView
	Network Administrators!
	Markup
	Linking
	User Profile Setup

	RxHighlight/RxView Configuration Options
	Network Administrators!
	Single Users
	Network Users
	Configuring

	Markup Layer Setup
	User Profile Setup
	Setting User Preferences
	Setting User Profiles
	Setting Markup Layers
	Saving Configuration Data


	Supported File Formats

